summaryrefslogtreecommitdiff
path: root/dev-libs/amdgpu-pro-opencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-libs/amdgpu-pro-opencl
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-libs/amdgpu-pro-opencl')
-rw-r--r--dev-libs/amdgpu-pro-opencl/Manifest2
-rw-r--r--dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/amdgpu-pro-opencl/Manifest b/dev-libs/amdgpu-pro-opencl/Manifest
index 56d93b6d497b..188ef258c224 100644
--- a/dev-libs/amdgpu-pro-opencl/Manifest
+++ b/dev-libs/amdgpu-pro-opencl/Manifest
@@ -1,3 +1,5 @@
DIST amdgpu-pro-17.50-511655.tar.xz 547875548 BLAKE2B c3e396d9846ca15297ecbfd8ff1c9ca3aae6352080f280dc13f2ad4d32da7b84a6d069fd4b64c6e4d9814459cc5cca1ab838295a83ede953a9df6cdcd1387f91 SHA512 d4d995eb596f94656d2fb6e43a2db29bcbfe28e09f75e19e23d1d446de899dbb6e4597ef833955a8b1788055fa848bc14e45a32c820ed8e97c667a784cf816cc
+DIST amdgpu-pro-18.20-606296.tar.xz 230733856 BLAKE2B 21a498a894a9712d9f0277fae7f704413be0cd01cebbe427008fa3d181d03b58268e74bd3cdaf0dfb9aeca2871dad82b4aa640bbce690ca461e3f3e4acf01ffd SHA512 6575bf963e5714657914d9116de4d9b1835851fe0609b1f072b1fbdf73c068da77aba0eca1c9cce6e05e6cd8f2c1ed6b4bd6ab4ef334be5ff796ee6a3ad73831
EBUILD amdgpu-pro-opencl-17.50.511655.ebuild 2308 BLAKE2B d0368da6709472e95c19b427bc6bca553c9569994d3ccf58d98e2fecff9fdc1a65a67c91ee6873631e4ebf539232500b433789590c6af547ca12fe42913b4625 SHA512 520e304dc4cd32745db6f7d9ef6286c45a496bbfc60281cf1dc8beedf0acfd078ba72d2cabaa5eb4132d93df74f29b2ae160d0c4bdbc78945c24e33561e1af12
+EBUILD amdgpu-pro-opencl-18.20.606296.ebuild 1838 BLAKE2B 5d9dc6a2fea24026f87d7273d5281b344ea2d3dbc4090c7516085bda7c5085e9ff9db99bd37945074b69b7d2f4b89fa6b0e452558d041a176cbc1ddadd4a262a SHA512 6a01ae72eaa059aa5d87b9e159ac02b2dcf42de6b85be87d7f2666d2f043ab17bcba0f316948d6d31d2b90c512f482620d2b261a9e86e569cedfc5f2aa852afa
MISC metadata.xml 656 BLAKE2B 5af3c00c551e7fd2b0de6d8c24421a58986ef20c24b7f2799a428dc7e07e2da4841ce93ade51edae33c0ba79dc55ed6df3452c0b5a610499e7e79e09c31b22de SHA512 5f6933f6ff6dd222a54e4c3609b888182ffd136bb0b58c905624cc9b404091b4e46917cf20d4d24585fa3ed710fb9881f3b6437e015371743d23d07fab488fb0
diff --git a/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild b/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild
new file mode 100644
index 000000000000..614f397a1b7e
--- /dev/null
+++ b/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+SUPER_PN='amdgpu-pro'
+MY_PV=$(ver_rs 2 '-')
+
+DESCRIPTION="Proprietary OpenCL implementation for AMD GPUs"
+HOMEPAGE="https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-for-Linux-Release-Notes.aspx"
+SRC_URI="${SUPER_PN}-${MY_PV}.tar.xz"
+
+LICENSE="AMD-GPU-PRO-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror fetch strip"
+
+DEPEND=""
+RDEPEND="dev-libs/ocl-icd"
+
+QA_PREBUILT="/opt/${SUPER_PN}/lib*/*"
+
+S="${WORKDIR}/${SUPER_PN}-${MY_PV}"
+
+pkg_nofetch() {
+ local pkgver=$(ver_cut 1-2)
+ einfo "Please download the Radeon Software for Linux Driver ${pkgver} for Ubuntu 16 from"
+ einfo " ${HOMEPAGE}"
+ einfo "The archive should then be placed into ${DISTDIR}."
+}
+
+src_unpack() {
+ default
+
+ cd "${S}" || die
+ unpack_deb opencl-orca-amdgpu-pro-icd_${MY_PV}_amd64.deb
+}
+
+src_install() {
+ into "/opt/amdgpu"
+ dolib.so opt/${SUPER_PN}/lib/x86_64-linux-gnu/*
+
+ insinto /etc/OpenCL/vendors/
+ echo "/opt/amdgpu/$(get_libdir)/libamdocl-orca64.so" > "${SUPER_PN}.icd" || die "Failed to generate ICD file"
+ doins "${SUPER_PN}.icd"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ ewarn "Please note that using proprietary OpenCL libraries together with the"
+ ewarn "Open Source amdgpu stack is not officially supported by AMD. Do not ask them"
+ ewarn "for support in case of problems with this package."
+ ewarn ""
+ ewarn "Furthermore, if you have the whole AMDGPU-Pro stack installed this package"
+ ewarn "will almost certainly conflict with it. This might change once AMDGPU-Pro"
+ ewarn "has become officially supported by Gentoo."
+ fi
+
+ elog "AMD OpenCL driver relies on dev-libs/ocl-icd to work. To enable it, please run"
+ elog ""
+ elog " eselect opencl set ocl-icd"
+ elog ""
+}