summaryrefslogtreecommitdiff
path: root/dev-libs/amdgpu-pro-opencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/amdgpu-pro-opencl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/amdgpu-pro-opencl')
-rw-r--r--dev-libs/amdgpu-pro-opencl/Manifest5
-rw-r--r--dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-17.50.552542.ebuild81
-rw-r--r--dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild66
-rw-r--r--dev-libs/amdgpu-pro-opencl/metadata.xml18
4 files changed, 170 insertions, 0 deletions
diff --git a/dev-libs/amdgpu-pro-opencl/Manifest b/dev-libs/amdgpu-pro-opencl/Manifest
new file mode 100644
index 000000000000..92ee3dae56c5
--- /dev/null
+++ b/dev-libs/amdgpu-pro-opencl/Manifest
@@ -0,0 +1,5 @@
+DIST amdgpu-pro-17.50-552542.tar.xz 549501204 BLAKE2B 37dcda126a3bda4e87b64ce260c7e4b65a1b864363c51f06e3152f152b83a60074331e6a0bf7b831c059a50192dea8add9b38ed16971c87293ce0e56ddf26bb2 SHA512 060e96609cf1a013fddf10db9bba4b512750e5188671a669e2582c28a03213b40d073031e35a617b982374d9d1cd4078f43b27053ee34be7c83873c0814ed196
+DIST amdgpu-pro-18.20-606296.tar.xz 230733856 BLAKE2B 21a498a894a9712d9f0277fae7f704413be0cd01cebbe427008fa3d181d03b58268e74bd3cdaf0dfb9aeca2871dad82b4aa640bbce690ca461e3f3e4acf01ffd SHA512 6575bf963e5714657914d9116de4d9b1835851fe0609b1f072b1fbdf73c068da77aba0eca1c9cce6e05e6cd8f2c1ed6b4bd6ab4ef334be5ff796ee6a3ad73831
+EBUILD amdgpu-pro-opencl-17.50.552542.ebuild 2324 BLAKE2B 1912cf7ced90db456b26978a516749e5f8531f92479288995ed68c3a4d81882f9e05ac704454c957a3218b3ef6414166d21aeb933ab3e0aeff9942653cfd4297 SHA512 86d9a1b05d85a8c367bf511f1d3739d419ac7c08bc13749d3384a420ffcc7989123626070922af508ebe9b0ea462c96339ef8a050de1544a787035c73f50c419
+EBUILD amdgpu-pro-opencl-18.20.606296.ebuild 1838 BLAKE2B 5d9dc6a2fea24026f87d7273d5281b344ea2d3dbc4090c7516085bda7c5085e9ff9db99bd37945074b69b7d2f4b89fa6b0e452558d041a176cbc1ddadd4a262a SHA512 6a01ae72eaa059aa5d87b9e159ac02b2dcf42de6b85be87d7f2666d2f043ab17bcba0f316948d6d31d2b90c512f482620d2b261a9e86e569cedfc5f2aa852afa
+MISC metadata.xml 656 BLAKE2B 5af3c00c551e7fd2b0de6d8c24421a58986ef20c24b7f2799a428dc7e07e2da4841ce93ade51edae33c0ba79dc55ed6df3452c0b5a610499e7e79e09c31b22de SHA512 5f6933f6ff6dd222a54e4c3609b888182ffd136bb0b58c905624cc9b404091b4e46917cf20d4d24585fa3ed710fb9881f3b6437e015371743d23d07fab488fb0
diff --git a/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-17.50.552542.ebuild b/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-17.50.552542.ebuild
new file mode 100644
index 000000000000..19adb74c35b8
--- /dev/null
+++ b/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-17.50.552542.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+SUPER_PN='amdgpu-pro'
+MY_PV=$(ver_rs 2 '-')
+
+DESCRIPTION="Proprietary OpenCL implementation for AMD GPUs"
+HOMEPAGE="https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-for-Linux-with-Vulkan-1.1-support.aspx"
+SRC_URI="${SUPER_PN}-${MY_PV}.tar.xz"
+
+LICENSE="AMD-GPU-PRO-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror fetch strip"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="dev-libs/ocl-icd"
+
+QA_PREBUILT="/opt/${SUPER_PN}/lib*/*"
+
+S="${WORKDIR}/${SUPER_PN}-${MY_PV}"
+
+pkg_nofetch() {
+ local pkgver=$(ver_cut 1-2)
+ einfo "Please download the Radeon Software for Linux Driver ${pkgver} for Ubuntu from"
+ einfo " ${HOMEPAGE}"
+ einfo "The archive should then be placed into ${DISTDIR}."
+}
+
+src_unpack() {
+ default
+
+ local ids_ver="1.0.0"
+ local libdrm_ver="2.4.82"
+ local patchlevel=$(ver_cut 3)
+ cd "${S}" || die
+ unpack_deb opencl-${SUPER_PN}-icd_${MY_PV}_amd64.deb
+ unpack_deb libdrm-amdgpu-amdgpu1_${libdrm_ver}-${patchlevel}_amd64.deb
+ unpack_deb ids-amdgpu_${ids_ver}-${patchlevel}_all.deb
+}
+
+src_prepare() {
+ default
+
+ cd "${S}/opt/${SUPER_PN}/lib/x86_64-linux-gnu" || die
+ patchelf --set-rpath '$ORIGIN' libamdocl64.so || die "Failed to fix library rpath"
+}
+
+src_install() {
+ into "/opt/amdgpu"
+ dolib.so opt/${SUPER_PN}/lib/x86_64-linux-gnu/*
+ dolib.so opt/amdgpu/lib/x86_64-linux-gnu/*
+ insinto "/opt/amdgpu"
+ doins -r opt/amdgpu/share
+
+ insinto /etc/OpenCL/vendors/
+ echo "/opt/amdgpu/$(get_libdir)/libamdocl64.so" > "${SUPER_PN}.icd" || die "Failed to generate ICD file"
+ doins "${SUPER_PN}.icd"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ ewarn "Please note that using proprietary OpenCL libraries together with the"
+ ewarn "Open Source amdgpu stack is not officially supported by AMD. Do not ask them"
+ ewarn "for support in case of problems with this package."
+ ewarn ""
+ ewarn "Furthermore, if you have the whole AMDGPU-Pro stack installed this package"
+ ewarn "will almost certainly conflict with it. This might change once AMDGPU-Pro"
+ ewarn "has become officially supported by Gentoo."
+ fi
+
+ elog "AMD OpenCL driver relies on dev-libs/ocl-icd to work. To enable it, please run"
+ elog ""
+ elog " eselect opencl set ocl-icd"
+ elog ""
+}
diff --git a/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild b/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild
new file mode 100644
index 000000000000..614f397a1b7e
--- /dev/null
+++ b/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+SUPER_PN='amdgpu-pro'
+MY_PV=$(ver_rs 2 '-')
+
+DESCRIPTION="Proprietary OpenCL implementation for AMD GPUs"
+HOMEPAGE="https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-for-Linux-Release-Notes.aspx"
+SRC_URI="${SUPER_PN}-${MY_PV}.tar.xz"
+
+LICENSE="AMD-GPU-PRO-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror fetch strip"
+
+DEPEND=""
+RDEPEND="dev-libs/ocl-icd"
+
+QA_PREBUILT="/opt/${SUPER_PN}/lib*/*"
+
+S="${WORKDIR}/${SUPER_PN}-${MY_PV}"
+
+pkg_nofetch() {
+ local pkgver=$(ver_cut 1-2)
+ einfo "Please download the Radeon Software for Linux Driver ${pkgver} for Ubuntu 16 from"
+ einfo " ${HOMEPAGE}"
+ einfo "The archive should then be placed into ${DISTDIR}."
+}
+
+src_unpack() {
+ default
+
+ cd "${S}" || die
+ unpack_deb opencl-orca-amdgpu-pro-icd_${MY_PV}_amd64.deb
+}
+
+src_install() {
+ into "/opt/amdgpu"
+ dolib.so opt/${SUPER_PN}/lib/x86_64-linux-gnu/*
+
+ insinto /etc/OpenCL/vendors/
+ echo "/opt/amdgpu/$(get_libdir)/libamdocl-orca64.so" > "${SUPER_PN}.icd" || die "Failed to generate ICD file"
+ doins "${SUPER_PN}.icd"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ ewarn "Please note that using proprietary OpenCL libraries together with the"
+ ewarn "Open Source amdgpu stack is not officially supported by AMD. Do not ask them"
+ ewarn "for support in case of problems with this package."
+ ewarn ""
+ ewarn "Furthermore, if you have the whole AMDGPU-Pro stack installed this package"
+ ewarn "will almost certainly conflict with it. This might change once AMDGPU-Pro"
+ ewarn "has become officially supported by Gentoo."
+ fi
+
+ elog "AMD OpenCL driver relies on dev-libs/ocl-icd to work. To enable it, please run"
+ elog ""
+ elog " eselect opencl set ocl-icd"
+ elog ""
+}
diff --git a/dev-libs/amdgpu-pro-opencl/metadata.xml b/dev-libs/amdgpu-pro-opencl/metadata.xml
new file mode 100644
index 000000000000..1a1bba3f0d9f
--- /dev/null
+++ b/dev-libs/amdgpu-pro-opencl/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>brovushkin+gentoo@gmail.com</email>
+ <name>Vladyslav Brovko</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package contains the libraries necessary to enable OpenCL support
+ on AMD GPUs supported by the amdgpu driver. The libraries themselves
+ are part of the proprietary AMDGPU-Pro suite but work fine with the
+ free amdgpu driver stack.
+ </longdescription>
+</pkgmetadata>