summaryrefslogtreecommitdiff
path: root/dev-libs/OpenNI/OpenNI-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-libs/OpenNI/OpenNI-9999.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-libs/OpenNI/OpenNI-9999.ebuild')
-rw-r--r--dev-libs/OpenNI/OpenNI-9999.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/dev-libs/OpenNI/OpenNI-9999.ebuild b/dev-libs/OpenNI/OpenNI-9999.ebuild
index aef879f68ea5..0febb7dba0b7 100644
--- a/dev-libs/OpenNI/OpenNI-9999.ebuild
+++ b/dev-libs/OpenNI/OpenNI-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/OpenNI/OpenNI"
fi
-inherit ${SCM} toolchain-funcs epatch multilib java-pkg-opt-2
+inherit ${SCM} toolchain-funcs multilib java-pkg-opt-2
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -31,18 +31,21 @@ RDEPEND="
virtual/jpeg:0
dev-libs/tinyxml
opengl? ( media-libs/freeglut !dev-libs/OpenNI2[opengl] )
- java? ( >=virtual/jre-1.5 )
+ java? ( virtual/jre:1.8 )
"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
- java? ( >=virtual/jdk-1.5 )"
+ java? ( virtual/jdk:1.8 )"
+
+PATCHES=(
+ "${FILESDIR}/tinyxml.patch"
+ "${FILESDIR}/jpeg.patch"
+ "${FILESDIR}/soname.patch"
+ "${FILESDIR}/${PN}-1.5.7.10-gcc6.patch"
+)
src_prepare() {
- epatch \
- "${FILESDIR}/tinyxml.patch" \
- "${FILESDIR}/jpeg.patch" \
- "${FILESDIR}/soname.patch" \
- "${FILESDIR}/${PN}-1.5.7.10-gcc6.patch"
+ default
rm -rf External/{LibJPEG,TinyXml}
for i in Platform/Linux/Build/Common/Platform.* Externals/PSCommon/Linux/Build/Platform.* ; do
@@ -89,7 +92,8 @@ src_install() {
dodoc Documentation/OpenNI_UserGuide.pdf CHANGES NOTICE README
if use doc ; then
- dohtml -r "${S}/Source/DoxyGen/html/"*
+ docinto html
+ dodoc -r "${S}/Source/DoxyGen/html/"*
dodoc Source/DoxyGen/Text/*.txt
fi