summaryrefslogtreecommitdiff
path: root/dev-libs/Ice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
commit8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (patch)
treeced0310e563ec21deb23ca12d5459aebadba36f6 /dev-libs/Ice
parent93c735f5f1ff867aadcc947348d984ff2c5a29cb (diff)
gentoo auto-resync : 30:03:2023 - 16:00:34
Diffstat (limited to 'dev-libs/Ice')
-rw-r--r--dev-libs/Ice/Ice-3.6.5-r2.ebuild336
-rw-r--r--dev-libs/Ice/Ice-3.7.8-r1.ebuild2
-rw-r--r--dev-libs/Ice/Ice-3.7.8.ebuild258
-rw-r--r--dev-libs/Ice/Manifest9
-rw-r--r--dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch50
-rw-r--r--dev-libs/Ice/files/Ice-3.6.5-csharp.patch50
-rw-r--r--dev-libs/Ice/files/Ice-3.6.5-db6.patch48
7 files changed, 2 insertions, 751 deletions
diff --git a/dev-libs/Ice/Ice-3.6.5-r2.ebuild b/dev-libs/Ice/Ice-3.6.5-r2.ebuild
deleted file mode 100644
index d7ea1ea0d531..000000000000
--- a/dev-libs/Ice/Ice-3.6.5-r2.ebuild
+++ /dev/null
@@ -1,336 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-RUBY_OPTIONAL="yes"
-USE_RUBY="ruby27"
-
-PHP_EXT_NAME="IcePHP"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-PHP_EXT_OPTIONAL_USE=php
-
-USE_PHP="php7-4"
-
-# This variable does not belong to any eclass. It is solely used in this ebuild
-BERKDB_SLOTS=( 6.2 6.1 5.3 5.1 4.8 )
-
-inherit db-use mono-env php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
-
-DESCRIPTION="ICE middleware C++ library and generator tools"
-HOMEPAGE="https://zeroc.com/products/ice"
-SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz
- doc? ( https://download.zeroc.com/Ice/$(ver_cut 1-2)/${PN}-3.6.4.pdf )"
-LICENSE="GPL-2"
-SLOT="0/36"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="debug doc examples +readline mono php python ruby test"
-RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=dev-libs/expat-2.0.1
- >=app-arch/bzip2-1.0.5
- dev-libs/openssl:0=
- virtual/libcrypt:=
- || (
- $(for slot in ${BERKDB_SLOTS[@]} ; do printf '%s\n' "sys-libs/db:${slot}[cxx]" ; done)
- )
- dev-cpp/libmcpp
- python? ( ${PYTHON_DEPS} )
- ruby? ( $(ruby_implementation_depend ruby27) )
- mono? ( dev-lang/mono )"
-DEPEND="${RDEPEND}
- readline? ( sys-libs/readline:0= )
- test? (
- ${PYTHON_DEPS}
- dev-python/passlib[${PYTHON_USEDEP}]
- )"
-
-# Maintainer notes:
-# TODO: java bindings
-
-S="${WORKDIR}/${P,}"
-PHP_EXT_S="${S}/php"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.6.3-no-arch-opts.patch"
- "${FILESDIR}/${P}-db6.patch"
- "${FILESDIR}/${P}-csharp.patch"
-)
-
-pkg_setup() {
- # prevent ruby-ng.eclass from messing with pkg_setup
- return
-}
-
-src_unpack() {
- # prevent ruby-ng.eclass from messing with src_unpack
- default
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|-L\$\(libdir\)||' \
- cpp/config/Make.rules || die
-
- sed -i \
- -e 's|-O2 ||g' \
- -e 's|-Werror ||g' \
- cpp/config/Make.rules.Linux || die
-
- sed -i \
- -e 's|install-common||' \
- {cpp,csharp,php,python,ruby}/Makefile || die
-
- sed -i \
- -e 's|-f -root|-f -gacdir $(GAC_DIR) -root|' \
- csharp/config/Make.rules.cs || die
-
- # skip mono tests, bug #498484
- sed -i \
- -e '/SUBDIRS/s|\ test||' \
- csharp/Makefile || die
-
- # skip udp test due to multicast
- # skip IceGrid/admin bug #649850
- # skip IceSSL tests due to requirement of internet connection
- # skip IceStorm/single bug #636834
- # IceUtil/stacktrace and IceStorm/stress fail with USE=debug
- # Glacier2/staticFiltering requires network access
- sed -i \
- -e 's|allTests.py|allTests.py --rfilter=udp --rfilter=IceGrid\/admin --rfilter=IceSSL --rfilter=IceStorm\/single --rfilter=IceStorm\/stress --rfilter=IceUtil\/stacktrace --rfilter=Glacier2\/staticFiltering|' \
- cpp/Makefile || die
-
- # fails even on unicode locale
- sed -i \
- -e 's|allTests.py|allTests.py --rfilter=Slice\/unicodePaths|' \
- ruby/Makefile || die
-
- # fix for x86 IceBox test
- sed -i \
- -e 's|"32"|""|' \
- scripts/TestUtil.py || die
-}
-
-src_configure() {
- suitable_db_version() {
- local ver
- for ver in "${BERKDB_SLOTS[@]}"; do
- if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then
- echo "${ver}"
- return 0
- fi
- done
- die "No suitable BerkDB versions found, aborting"
- }
-
- MAKE_RULES=(
- "prefix=\"${ED}/usr\""
- "install_docdir=\"${ED}/usr/share/doc/${PF}\""
- "install_configdir=\"${ED}/usr/share/${P}/config\""
- "install_mandir=\"${ED}/usr/share/man/man1\""
- "embedded_runpath_prefix=\"${EPREFIX}/usr\""
- "LP64=yes"
- "new_dtags=yes"
- "NOTEST=$(usex !test)"
- "USE_READLINE=$(usex readline)"
- "OPTIMIZE=$(usex !debug)"
- )
-
- local BERKDB_VERSION="$(suitable_db_version)"
- MAKE_RULES+=("DB_FLAGS=-I$(db_includedir ${BERKDB_VERSION})")
- sed -i \
- -e "s|g++|$(tc-getCXX)|" \
- -e "s|\(CFLAGS[[:space:]]*=\)|\1 ${CFLAGS}|" \
- -e "s|\(CXXFLAGS[[:space:]]*=\)|\1 ${CXXFLAGS}|" \
- -e "s|\(LDFLAGS[[:space:]]*=\)|\1 ${LDFLAGS}|" \
- -e "s|\(DB_LIBS[[:space:]]*=\) \-ldb_cxx|\1 -ldb_cxx-$(db_findver sys-libs/db:${BERKDB_VERSION})|" \
- cpp/config/Make.rules{,.Linux} python/config/Make.rules || die
-
- if use python; then
- local S="${S}/python"
- python_copy_sources
- fi
-
- if use ruby; then
- SITERUBY="$(ruby26 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
- SITERUBYARCH="$(ruby26 -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')"
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${ED}/${SITERUBY}\""
- "install_libdir=\"${ED}/${SITERUBYARCH}\""
- )
-
- # make it use ruby26 only
- sed -i \
- -e 's|RUBY = ruby|\026|' \
- ruby/config/Make.rules || die
- sed -i \
- -e 's|env ruby|\026|' \
- ruby/config/s2rb.rb || die
- sed -i \
- -e 's|env ruby|\026|' \
- ruby/scripts/slice2rb || die
- sed -i \
- -e 's|output.write("ruby|\026|' \
- scripts/TestUtil.py || die
- fi
-
- MAKE_RULES_MONO=(
- "GACINSTALL=yes"
- "GAC_ROOT=\"${ED}/usr/$(get_libdir)\""
- "GAC_DIR=\"${EPREFIX}/usr/$(get_libdir)\""
- "install_libdir=\"${ED}/usr/$(get_libdir)\""
- "install_pkgconfigdir=\"${ED}/usr/$(get_libdir)/pkgconfig\""
- )
-
- if has_version ">dev-lang/mono-4"; then
- MAKE_RULES_MONO+=("MCS=mcs")
- fi
-
- use test && python_setup
-}
-
-src_compile() {
- # Do not remove this export or build will break!
- tc-export CXX
-
- emake -C cpp "${MAKE_RULES[@]}"
-
- if use php; then
- local i
- for i in $(php_get_slots); do
- mkdir -p "${WORKDIR}/${i}" || die
- cp -r "${PHP_EXT_S}" "${WORKDIR}/${i}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
-
- pushd "${WORKDIR}/${i}" >/dev/null || die
- ln -s "${S}/cpp" || die
- ln -s "${S}/config" || die
- ln -s "${S}/slice" || die
- ln -s "${S}/Makefile" || die
-
- emake -C php "${MAKE_RULES[@]}" USE_NAMESPACES=yes "PHP_CONFIG=\"${EPREFIX}/usr/$(get_libdir)/${i}/bin/php-config\""
- popd >/dev/null || die
- done
- fi
-
- if use python; then
- building() {
- emake -C "${BUILD_DIR}" "${MAKE_RULES[@]}" PYTHON="${EPYTHON}"
- }
- local S="${S}/python"
- python_foreach_impl building
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}"
- fi
-
- if use mono; then
- emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}"
- fi
-}
-
-src_test() {
- local -x LD_LIBRARY_PATH="${S}/cpp/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
- emake -C cpp "${MAKE_RULES[@]}" test
-
- # php tests require the extension loaded and are therefore skipped
-
- if use python; then
- testing() {
- PYTHONPATH="${BUILD_DIR}"/python emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- PYTHON="${EPYTHON}" \
- install_pythondir="\"${D}/$(python_get_sitedir)\"" \
- install_libdir="\"${D}/$(python_get_sitedir)\"" test
- }
- local S="${S}/python"
- python_foreach_impl testing
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" test
- fi
-
- if use mono; then
- # skip mono tests, bug #498484
- ewarn "Tests for C# are currently disabled."
- #emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}" test
- fi
-}
-
-src_install() {
- local DOCS=( CHANGELOG*.md README.md )
- use doc && DOCS+=( "${DISTDIR}/${PN}-3.6.4.pdf" )
- einstalldocs
-
- insinto /usr/share/${P}
- doins -r slice
-
- emake -C cpp "${MAKE_RULES[@]}" install
-
- if use examples; then
- docinto examples-cpp
- dodoc cpp/config/*.cfg
- docompress -x /usr/share/doc/${PF}/examples-cpp
- fi
-
- if use php; then
- insinto "/usr/share/php/${PN}"
-
- local i
- while IFS="" read -d $'\0' -r i; do
- doins "${i}"
- done < <(find "${S}/php/lib/" -name '*.php' -print0)
-
- pushd "${ED}/usr/share/${P}/slice" >/dev/null || die
-
- local -x LD_LIBRARY_PATH="${ED}/usr/$(get_libdir):${LD_LIBRARY_PATH}"
- for i in *; do
- mkdir -p "${ED}/usr/share/php/${i}" || die
- "${ED}"/usr/bin/slice2php \
- -I"${ED}/usr/share/${P}/slice/" --all \
- --output-dir "${ED}/usr/share/php/${i}" \
- --ice "${ED}/usr/share/${P}/slice/${i}"/*
- done
-
- for i in $(php_get_slots); do
- php_init_slot_env "${i}"
- insinto "${EXT_DIR}"
- newins "php/lib/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
- done
- php-ext-source-r3_createinifiles
-
- popd >/dev/null || die
- fi
-
- if use python; then
- installation() {
- mkdir -p "${D}/$(python_get_sitedir)" || die
-
- emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- install_pythondir="\"${D}/$(python_get_sitedir)\"" \
- install_libdir="\"${D}/$(python_get_sitedir)\"" \
- install
- python_optimize
- }
- local S="${S}/python"
- python_foreach_impl installation
- fi
-
- if use ruby; then
- dodir "${SITERUBY}"
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" install
- fi
-
- if use mono; then
- emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}" install
- fi
-}
diff --git a/dev-libs/Ice/Ice-3.7.8-r1.ebuild b/dev-libs/Ice/Ice-3.7.8-r1.ebuild
index 40345ee3fabd..4def5e25988d 100644
--- a/dev-libs/Ice/Ice-3.7.8-r1.ebuild
+++ b/dev-libs/Ice/Ice-3.7.8-r1.ebuild
@@ -24,7 +24,7 @@ SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz
doc? ( https://download.zeroc.com/Ice/$(ver_cut 1-2)/${PN}-3.7.1.pdf )"
LICENSE="GPL-2"
SLOT="0/37"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="debug doc examples php python ruby test"
RESTRICT="test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
diff --git a/dev-libs/Ice/Ice-3.7.8.ebuild b/dev-libs/Ice/Ice-3.7.8.ebuild
deleted file mode 100644
index a512d98ba711..000000000000
--- a/dev-libs/Ice/Ice-3.7.8.ebuild
+++ /dev/null
@@ -1,258 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-RUBY_OPTIONAL="yes"
-USE_RUBY="ruby27"
-
-PHP_EXT_NAME="IcePHP"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-PHP_EXT_OPTIONAL_USE=php
-
-USE_PHP="php8-0 php8-1 php8-2"
-
-inherit php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
-
-DESCRIPTION="ICE middleware C++ library and generator tools"
-HOMEPAGE="https://zeroc.com/products/ice"
-SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz
- doc? ( https://download.zeroc.com/Ice/$(ver_cut 1-2)/${PN}-3.7.1.pdf )"
-LICENSE="GPL-2"
-SLOT="0/37"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="debug doc examples php python ruby test"
-RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=app-arch/bzip2-1.0.5
- >=dev-libs/expat-2.0.1
- dev-libs/libedit
- dev-cpp/libmcpp
- dev-db/lmdb:=
- dev-libs/openssl:0=
- virtual/libcrypt:=
- python? ( ${PYTHON_DEPS} )
- ruby? ( $(ruby_implementation_depend ruby27) )"
-DEPEND="${RDEPEND}
- test? (
- ${PYTHON_DEPS}
- dev-python/passlib[${PYTHON_USEDEP}]
- )"
-
-# Maintainer notes:
-# TODO: java bindings
-
-S="${WORKDIR}/${P,}"
-PHP_EXT_S="${S}/php"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-musl-build.patch"
- "${FILESDIR}/${P}-py3k11.patch"
-)
-
-pkg_setup() {
- # prevent ruby-ng.eclass from messing with pkg_setup
- return
-}
-
-src_unpack() {
- # prevent ruby-ng.eclass from messing with src_unpack
- default
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|-Werror ||g' \
- config/Make.rules.Linux || die
-
- # fix for x86 IceBox test
- sed -i \
- -e 's|"32"|""|' \
- scripts/IceBoxUtil.py || die
-
- if use !test; then
- # Disable building tests
- sed -i \
- -e 's|include \$(top_srcdir)/config/Make.tests.rules||' \
- config/Make.rules || die
- fi
-}
-
-src_configure() {
- MAKE_RULES=(
- "embedded_runpath_prefix=\"${EPREFIX}/usr\""
- "OPTIMIZE=$(usex !debug)"
- "V=1"
- )
-
- if use python; then
- local S="${S}/python"
- python_copy_sources
- fi
-
- if use ruby; then
- SITERUBY="$(ruby27 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
- SITERUBYARCH="$(ruby27 -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')"
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${EPREFIX}/${SITERUBY}\""
- "install_rubylibdir=\"${EPREFIX}/${SITERUBYARCH}\""
- )
-
- # make it use ruby27 only
- sed -i \
- -e 's|RUBY ?= ruby|\027|' \
- ruby/config/Make.rules || die
- sed -i \
- -e 's|env ruby|\027|' \
- ruby/config/s2rb.rb || die
- sed -i \
- -e 's|env ruby|\027|' \
- ruby/scripts/slice2rb || die
- fi
-
- use test && python_setup
-}
-
-src_compile() {
- # Do not remove this export or build will break!
- tc-export CXX
-
- emake -C cpp "${MAKE_RULES[@]}"
-
- if use php; then
- local i
- for i in $(php_get_slots); do
- mkdir -p "${WORKDIR}/${i}" || die
- cp -r "${PHP_EXT_S}" "${WORKDIR}/${i}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
-
- pushd "${WORKDIR}/${i}" >/dev/null || die
- ln -s "${S}/cpp" || die
- ln -s "${S}/config" || die
- ln -s "${S}/slice" || die
- ln -s "${S}/Makefile" || die
-
- emake -C php "${MAKE_RULES[@]}" "PHP_CONFIG=\"${EPREFIX}/usr/$(get_libdir)/${i}/bin/php-config\""
- popd >/dev/null || die
- done
- fi
-
- if use python; then
- building() {
- emake -C "${BUILD_DIR}" "${MAKE_RULES[@]}" PYTHON="${EPYTHON}"
- }
- local S="${S}/python"
- python_foreach_impl building
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}"
- fi
-}
-
-src_test() {
- local -x LD_LIBRARY_PATH="${S}/cpp/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
- emake -C cpp "${MAKE_RULES[@]}" test
-
- # php tests require the extension loaded and are therefore skipped
-
- if use python; then
- testing() {
- PYTHONPATH="${BUILD_DIR}"/python emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- PYTHON="${EPYTHON}" \
- install_pythondir="\"$(python_get_sitedir)\"" \
- install_libdir="\"$(python_get_sitedir)\"" test
- }
- local S="${S}/python"
- python_foreach_impl testing
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" test
- fi
-}
-
-src_install() {
- local DOCS=( CHANGELOG*.md README.md )
- use doc && DOCS+=( "${DISTDIR}/${PN}-3.7.1.pdf" )
- einstalldocs
-
- MAKE_RULES_INSTALL=(
- "prefix=\"${ED}/usr\""
- "install_docdir=\"${ED}/usr/share/doc/${PF}\""
- "install_configdir=\"${ED}/usr/share/${P}/config\""
- "install_mandir=\"${ED}/usr/share/man/man1\""
- )
-
- insinto /usr/share/${P}
- doins -r slice
-
- emake -C cpp "${MAKE_RULES[@]}" "${MAKE_RULES_INSTALL[@]}" install
-
- if use examples; then
- docinto examples-cpp
- dodoc cpp/config/*.cfg
- docompress -x /usr/share/doc/${PF}/examples-cpp
- fi
-
- if use php; then
- insinto "/usr/share/php/${PN}"
-
- local i
- while IFS="" read -d $'\0' -r i; do
- doins "${i}"
- done < <(find "${S}/php/lib/" -name '*.php' -print0)
-
- pushd "${ED}/usr/share/${P}/slice" >/dev/null || die
-
- local -x LD_LIBRARY_PATH="${ED}/usr/$(get_libdir):${LD_LIBRARY_PATH}"
- for i in *; do
- mkdir -p "${ED}/usr/share/php/${i}" || die
- "${ED}"/usr/bin/slice2php \
- -I"${ED}/usr/share/${P}/slice/" --all \
- --output-dir "${ED}/usr/share/php/${i}" \
- --ice "${ED}/usr/share/${P}/slice/${i}"/*
- done
-
- for i in $(php_get_slots); do
- php_init_slot_env "${i}"
- insinto "${EXT_DIR}"
- newins "php/lib/ice.so" "${PHP_EXT_NAME}.so"
- done
- php-ext-source-r3_createinifiles
-
- popd >/dev/null || die
- fi
-
- if use python; then
- installation() {
- mkdir -p "${D}/$(python_get_sitedir)" || die
-
- emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- "${MAKE_RULES_INSTALL[@]}" \
- install_pythondir="\"${D}/$(python_get_sitedir)\"" \
- install_libdir="\"${D}/$(python_get_sitedir)\"" \
- install
- python_optimize
- }
- local S="${S}/python"
- python_foreach_impl installation
- fi
-
- if use ruby; then
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${ED}/${SITERUBY}\""
- "install_rubylibdir=\"${ED}/${SITERUBYARCH}\""
- )
- dodir "${SITERUBY}"
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_INSTALL[@]}" "${MAKE_RULES_RUBY[@]}" install
- fi
-}
diff --git a/dev-libs/Ice/Manifest b/dev-libs/Ice/Manifest
index 20de8588b897..33bdb51569dc 100644
--- a/dev-libs/Ice/Manifest
+++ b/dev-libs/Ice/Manifest
@@ -1,14 +1,7 @@
-AUX Ice-3.6.3-no-arch-opts.patch 1462 BLAKE2B 0adbbb302a3fde0dab4dba0b5947ee5da3413a8c3dc02fb8612837f4a2b3ecb56b92628430d8f3c2315f1fb0fa057bf0942dd389941b61d70d12b4078ce45d84 SHA512 236abce89a7bcf64d6a12db5a82d62db1effa2b5a105ae7c83910f02ca1ccd610193097a2c959d2a487f0d641af70ba8013bcfe570e2af40976d9a1017272e6e
-AUX Ice-3.6.5-csharp.patch 1573 BLAKE2B 2e69e87179bd938bb34f1ae9826b09b935cb9a13e5f68fc81a6302afb66e4b4f45f1c22975cd3e2bc29e044dd7d47b120a93ea546d56cee93b6ee8f2a4af15f5 SHA512 7930b143b10da6521877c921b7b8dabb97b688ea8219dfb6cd2bbecf609cdcd07dcf4c2f80394a07337939d7ce42cb10bb1aed12885aa533e9ad9dec30ac6b87
-AUX Ice-3.6.5-db6.patch 1664 BLAKE2B 9ef67c83612875c68dd8fb7cea025ce3fca1e4384335108aa423ca63b53c6c723d9f7f9fd8fdc6895f8aedee0826efc225d89e487f5c95c395a8cdb1b893826a SHA512 ba94bddf3f43688ca74e5fd42fbafd7d0b6f02f616dfa4b6aff69ef1089f4404618cf07871d265b0b07037ca02a27fc397767d845a7e0edc60baa37704a064f0
AUX Ice-3.7.8-fix-musl-build.patch 568 BLAKE2B e320641208d46b27acc68d932aed336bf74407e3db8351e59b43172be771fe80ba813e01812a40b2cd57bd8002a0fe707f9a32fdef3f7b323c8a764f7f1c5c97 SHA512 be19a21ff3d4ddafb9d1b9c866f392b3eb081e450b9a061884485b7713f06ad5a7c58a0275328de8bdf39d0bfb2fcc085583105f47cae51e6cae42651a04ed3e
AUX Ice-3.7.8-py3k11.patch 1500 BLAKE2B c7580ff44b3d29071f48c72c00069e9689d8e6d354027469b70c14b249bc1b8c4b7453df02a4282066869b936a3f71e850d17a93444f1b192ccfb9998d8e632b SHA512 ebe4e8458785d4191f42fca81995f31c9e7d6e9290a91491ef311b2104c193161b5d3a8489a34630e0d42cb9dd3870e3f48fe8089b8f0739afbe822e1a9db4fb
-DIST Ice-3.6.4.pdf 8907736 BLAKE2B 5a631c1e2e147c8ed3b31a84192210c92bbe83e8644ec9d7d164d1b94a20069ce77f6baf54910ac00c7216cbc2979caac6fa78457e9292a84407e93000f9903a SHA512 9bd2d373eb83e08e563cab174a53063a490367dea3e4b910f93f0477c3817282c859f07e46e503006e9bd37678fb6da31a58b88bfabd217b5e371fff685321a0
-DIST Ice-3.6.5.tar.gz 5505499 BLAKE2B e16e8932f09270ac6bb86984ab47fa229ad873ee343ac4f56bb48b6f9547387ded0392a76302afac2c98b6d31da7c1faf294574cdba52654e7dea0af16b4169d SHA512 3431928e6168d716919aa9b3126d17a8ae14895bb78a369902a2bb350b2e82923f38ee17965ed3696512a016fcd34dc128e9aaca40fb2b032e7f7eb07bcb903b
DIST Ice-3.7.1.pdf 9351739 BLAKE2B 527f2c37aea19aedbfc580efd93ce4fae2eb7264342bb485822593e2da6fb75a61eea2b1a46187898af07f138d10bf9a213d0b2a0685c18cd1d4c624709a935b SHA512 199b59f14b87b2896ba970bf5aa32f6fd858cbd3fed18eac93acafe4e296db1361ca2d2000ed49f3390ed66c1d4ff8c1fcd3f14ab8197d7804c87fce422c8486
DIST Ice-3.7.8.tar.gz 11056950 BLAKE2B 66686d6e66a997badef53ee30782775047a2fa39d70fa8ed73c5e7a1bad3c3899efd8d68f557a416caacd65860a73834a6bdc3188730fa19a3f1e47f028c5e21 SHA512 eb5863cb5e83000199c27a5a505a19e5f1ec05e8575eb9cdc03f6db30447212e3b02e6adc70fb2ae6ddc63cfd93bc2b6b290f38919364ee9f08b238a0aa11e88
-EBUILD Ice-3.6.5-r2.ebuild 8488 BLAKE2B d65a635f6955e72794a7235566e24026f9d355418b4b5d34f0c4e55e7bbab2034afd84e13ea518ea1ebd73ad50f7420b17946298ff1a4bcb63431bd5efccdad0 SHA512 ad1e5fba85b750b9487abda43e6c7ea7e2ae84327905a5dd0e42946571e8cb62d07cb678152c1a900ca3cc0318d0a40f7129bd65f2d93a4a2a887dc6fa697386
-EBUILD Ice-3.7.8-r1.ebuild 5997 BLAKE2B 592e70feef2b6553a4c368b106046bf548bdf616f4c4c367b6156dcfa1dbb27800406f539f9375eba073831d226fa0feb10bdee9bcab10fbd2ac8f4055924d5a SHA512 c2068a8154d6b2b2115b27e6cc3bd1f20966089d6fd47af6d5c267b808a7aeb0709d540bbfad44ceb3b9d5ffe44eed0507305fa91ab063f76a2e572befe38ecc
+EBUILD Ice-3.7.8-r1.ebuild 5995 BLAKE2B 57a5cd9d4b7afcf752a3cdfbe6fc4c875c66a45557c1971c29b53437161d74175b1653b4d938fce801e68171ec970536c05e610c59fac37cf6b9b1cd297d6da9 SHA512 cee1fd3b34e0b085f8bcbecca48c5957ce75cadffa6d8b69b4731ff42f3b2582a8e9535804daefd8f782a9d8cf9f366be089ca9b21f6b9bfccb73a675b9cf971
EBUILD Ice-3.7.8-r2.ebuild 5997 BLAKE2B 057719846ad747e25383c1e31a8a08fc236632df6ac9eb567723a3cca76ca02a2efe1f7d1b48dc109cab5dbd920f56c56a23decee359905574a6c6b803ec9093 SHA512 ff0c5b979d24e82ac0a017598cfc00fd4a06aca695b1c7a829c78690aab6dc57303318476a5a3dacf63e56fc3216ed0b41caf2b1175a3ea3918201981e710059
-EBUILD Ice-3.7.8.ebuild 5997 BLAKE2B c190b9021e9b9bef11eda6510117f2cc9a14a3db959349576c56c8eb362772266d7f6d4da5bcefec8535cafefa3e48cb748a2a6f3d8777ed639c8862b25d824b SHA512 97926e476be3402d80fba869c2aef7678e8e55a671a958e0135dcb676e63135d6a3b11eade12b2fbfeb232fa8112a2e433da342c92f9160a41354dabdbcb4146
MISC metadata.xml 471 BLAKE2B 50fef5d9314fcf793c140c97016a5af4ecb2b1aa5cc86e8cd1f961beb1e55aeb23d1228bf9dcccb10d54458b72766eba80c9b18d9add7928fdd4197577e58971 SHA512 65d2e51347c27ee6414f07a69ecd886d9eb6a18b3419a80e0e7022bdf127b03fca0cdb954c5a3d46dba29e40dc7973a7c5d6b8388af36702c3874e02589cad56
diff --git a/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch b/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch
deleted file mode 100644
index 149a31e1dd6c..000000000000
--- a/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- ice-3.6.3/cpp/config/Make.rules.Linux~ 2015-06-27 16:56:56.000000000 +0200
-+++ ice-3.6.3/cpp/config/Make.rules.Linux 2015-06-27 17:23:45.810591931 +0200
-@@ -79,19 +79,6 @@
- CXXARCHFLAGS += -mtune=v8 -pipe -Wno-deprecated -DICE_USE_MUTEX_SHARED
- endif
-
-- #
-- # Only use multilib -m32/-m64 options for amd64 arch, x32 arch can also run
-- # in amd64 macines but doesn't use multilib, in this case MACHINE_TYPE will
-- # be x86_64 and HOST_ARCH x32.
-- #
-- ifeq ($(HOST_ARCH),amd64)
-- ifeq ($(LP64),yes)
-- CXXARCHFLAGS += -m64
-- else
-- CXXARCHFLAGS += -m32
-- endif
-- endif
--
- CXXFLAGS += $(CXXARCHFLAGS) -fvisibility=hidden -Wall -Werror -pthread
-
- # If MAXWARN is set then enable extra warnings
---- ice-3.6.3/config/Make.common.rules~ 2015-06-23 17:30:20.000000000 +0200
-+++ ice-3.6.3/config/Make.common.rules 2015-06-28 01:53:57.149666595 +0200
-@@ -101,25 +101,7 @@
- ifeq ($(LP64),)
- LP64 = yes
- endif
--
-- #
-- # x86 binaries build on x86_64 machine use 32 binsuffix
-- #
-- ifneq ($(STATICLIBS),yes)
-- ifneq ($(LP64),yes)
-- binsuffix = 32
-- endif
-- endif
- endif
--
-- #
-- # x86 builds uses 32 binsuffix
-- #
-- ifneq ($(STATICLIBS),yes)
-- ifeq ($(findstring $(MACHINE_TYPE),i386 i486 i586 i686),$(MACHINE_TYPE))
-- binsuffix = 32
-- endif
-- endif
- endif
-
- ifeq ($(CPP11),yes)
diff --git a/dev-libs/Ice/files/Ice-3.6.5-csharp.patch b/dev-libs/Ice/files/Ice-3.6.5-csharp.patch
deleted file mode 100644
index cfdc1f6a8d47..000000000000
--- a/dev-libs/Ice/files/Ice-3.6.5-csharp.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- ice-3.6.5/csharp/src/Makefile~ 2015-06-23 17:30:20.000000000 +0200
-+++ ice-3.6.5/csharp/src/Makefile 2015-06-27 20:07:04.217188211 +0200
-@@ -11,7 +11,7 @@
-
- include $(top_srcdir)/config/Make.rules.cs
-
--SUBDIRS = Ice IceStorm Glacier2 IcePatch2 IceGrid IceBox IceDiscovery IceLocatorDiscovery
-+SUBDIRS = Ice IceStorm Glacier2 IcePatch2 IceGrid IceBox IceSSL IceDiscovery IceLocatorDiscovery
-
- $(EVERYTHING)::
- @for subdir in $(SUBDIRS); \
---- /dev/null 2015-06-27 16:44:15.733558105 +0200
-+++ ice-3.6.5/csharp/lib/pkgconfig/IceSSL.pc 2015-06-27 20:19:30.731894653 +0200
-@@ -0,0 +1,10 @@
-+version = 3.6.5
-+mono_root = /usr
-+
-+name = IceSSL
-+
-+Name: ${name}
-+Description: IceSSL run-time support
-+Version: ${version}
-+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
-+Requires: Ice = ${version}
---- /dev/null 2015-06-27 16:44:15.733558105 +0200
-+++ ice-3.6.5/csharp/lib/pkgconfig/IceDiscovery.pc 2015-06-27 20:20:44.312515987 +0200
-@@ -0,0 +1,10 @@
-+version = 3.6.5
-+mono_root = /usr
-+
-+name = IceDiscovery
-+
-+Name: ${name}
-+Description: IceDiscovery run-time support
-+Version: ${version}
-+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
-+Requires: Ice = ${version}
---- /dev/null 2015-06-27 16:44:15.733558105 +0200
-+++ ice-3.6.5/csharp/lib/pkgconfig/IceLocatorDiscovery.pc 2015-06-27 20:21:22.206185123 +0200
-@@ -0,0 +1,10 @@
-+version = 3.6.5
-+mono_root = /usr
-+
-+name = IceLocatorDiscovery
-+
-+Name: ${name}
-+Description: IceLocatorDiscovery run-time support
-+Version: ${version}
-+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
-+Requires: Ice = ${version}
diff --git a/dev-libs/Ice/files/Ice-3.6.5-db6.patch b/dev-libs/Ice/files/Ice-3.6.5-db6.patch
deleted file mode 100644
index b78fae76a453..000000000000
--- a/dev-libs/Ice/files/Ice-3.6.5-db6.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Avoid ambiguous ctor call (uint32_t vs DB_ENV*) with db 6.x.
-
---- ice-3.6.3/cpp/src/Freeze/SharedDbEnv.cpp.orig 2016-10-05 16:59:08.000000000 +0200
-+++ ice-3.6.3/cpp/src/Freeze/SharedDbEnv.cpp 2017-06-28 18:42:43.411869639 +0200
-@@ -530,7 +530,7 @@
- {
- if(_env == 0)
- {
-- _envHolder.reset(new DbEnv(0));
-+ _envHolder.reset(new DbEnv(0u));
- _env = _envHolder.get();
-
- if(_trace >= 1)
---- ice-3.6.3/cpp/src/FreezeScript/transformdb.cpp.orig 2016-10-05 16:59:08.000000000 +0200
-+++ ice-3.6.3/cpp/src/FreezeScript/transformdb.cpp 2017-06-28 19:15:03.928514164 +0200
-@@ -766,8 +766,8 @@
- //
- // Transform the database.
- //
-- DbEnv dbEnv(0);
-- DbEnv dbEnvNew(0);
-+ DbEnv dbEnv(0u);
-+ DbEnv dbEnvNew(0u);
- Freeze::TransactionPtr txNew;
- Freeze::ConnectionPtr connection;
- Freeze::ConnectionPtr connectionNew;
---- ice-3.6.3/cpp/src/FreezeScript/Util.cpp.orig 2016-10-05 16:59:08.000000000 +0200
-+++ ice-3.6.3/cpp/src/FreezeScript/Util.cpp 2017-06-28 19:22:29.318509063 +0200
-@@ -209,7 +209,7 @@
- {
- CatalogDataMap result;
-
-- DbEnv dbEnv(0);
-+ DbEnv dbEnv(0u);
- try
- {
- #ifdef _WIN32
---- ice-3.6.3/cpp/src/FreezeScript/DumpDB.cpp.orig 2016-10-05 16:59:08.000000000 +0200
-+++ ice-3.6.3/cpp/src/FreezeScript/DumpDB.cpp 2017-06-28 19:33:38.555168088 +0200
-@@ -481,7 +481,7 @@
- FreezeScript::ObjectFactoryPtr objectFactory = new FreezeScript::ObjectFactory;
- communicator->addObjectFactory(objectFactory, "");
-
-- DbEnv dbEnv(0);
-+ DbEnv dbEnv(0u);
- DbTxn* txn = 0;
- Freeze::ConnectionPtr connection;
- int status = EXIT_SUCCESS;