summaryrefslogtreecommitdiff
path: root/dev-lang/zig
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 15:30:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 15:30:24 +0000
commit9b921f0a27acb73f29835bcf94b91bbdef87e9de (patch)
treea20561c628642e6e518ffac7df78980360a7ff8b /dev-lang/zig
parent05a3b7c2189f095dfc46fbb03d4b3e801d3dc13a (diff)
gentoo auto-resync : 14:12:2022 - 15:30:24
Diffstat (limited to 'dev-lang/zig')
-rw-r--r--dev-lang/zig/Manifest4
-rw-r--r--dev-lang/zig/zig-0.10.0.ebuild13
-rw-r--r--dev-lang/zig/zig-9999.ebuild11
3 files changed, 16 insertions, 12 deletions
diff --git a/dev-lang/zig/Manifest b/dev-lang/zig/Manifest
index 0791a5d16354..567831d3ea25 100644
--- a/dev-lang/zig/Manifest
+++ b/dev-lang/zig/Manifest
@@ -1,4 +1,4 @@
DIST zig-0.10.0.tar.xz 14530912 BLAKE2B 5949a44ee039b7d5a163344a0fc26af8dd9cf311ed25c7092a665bb59ec7dec8dc3cd39918d81ef02c707aa8989b038fb21dfba3927fd31153a1404739b4ea3c SHA512 9d83ce51cc0ce404c06da820179c1cc47aa50e573fb1c831a96baa12c6b5226abe85b384110f2ffc4cbdc5f24eaba1f14a4e3249ffeaa248c0d73ba29859e682
-EBUILD zig-0.10.0.ebuild 2540 BLAKE2B 79d46569b4707027657c25c7dcba54dfdd48fefd2d3ea4b92843888f4a1d7268fde05b55662888fad0deb7ce2ac407fdcf598c1046eb9d841737c65d58fb2f5c SHA512 e89bb8ca55df6bfc1d3d937157fa69422a53038ebdd605bac4dc4d4b927ef79c1e524fa6d298d35e38ce7405be8578441dafcedb6f82bf2f6ee04212053d8c55
-EBUILD zig-9999.ebuild 1856 BLAKE2B 383772a93b4d7c5bf7d84f0627fc05fd9494de1c9bcd54fa0c1fefa409bf177d4d45c2cc1066ef1a08afa069d4fbcd07baa02f28186577f9744da95dfa97fc63 SHA512 4fc3f4a558d9fce7ff16aea5d25bb8757a8781f82270a850ddc7dd5ba4ca04537a6370e25ecabba4e482edc05f162e3a8c43ba715224f2c80032d82fc088699a
+EBUILD zig-0.10.0.ebuild 2797 BLAKE2B 30422ca28bc6bbd61ac5381e59189a96916acb6963670d8ffe0a12b64ace4be8a72a55ac11af485dbe7c806f81d1aaaa1febb6fafa6ffa24704d9301bab6f1c4 SHA512 98ff2f9be1c0eb3327e7645ff3c74d010b15f4ea315fcaeb5c5fc85de5c49d96b7dffa487d1f05be256cef0791c2fb8628788572f41dda70294e70cf68edc2b8
+EBUILD zig-9999.ebuild 1671 BLAKE2B b753bbd37c7f1f60bdb2bc8fe3914d21f5b30787768460b55bd9e1980dc4727eb4f71c63a03da17a8a98c681df5e33e311b48c9c42fde8ab1b43a3bc9b3f4f90 SHA512 2b4d5a8fdfe5eba60896915b81168d5eb0aa3bcf53d6df8326c593f275556cf8652c401f0780f977325e877d36aa9348a196168f3e2c3dc3af99a8f5a1b46301
MISC metadata.xml 541 BLAKE2B 6f5c7fbf759f0430f69073a17a0dae4b8bebf335b54c3b43da6b24104dc3de05a3b686cddbbd31e4dae1fc31695a2f08d000d22437ed6f1847de8fa95e3b1952 SHA512 d49cf0a8ad76ac9a6f6fb091effddbbcd812b56f91df6d3c782e15197cb4ff4423fb1076671a232aabcb9833af19ef8c820ad6df312a1e4d72e665680314c083
diff --git a/dev-lang/zig/zig-0.10.0.ebuild b/dev-lang/zig/zig-0.10.0.ebuild
index 0ab54280a9ba..c4a1219ddb22 100644
--- a/dev-lang/zig/zig-0.10.0.ebuild
+++ b/dev-lang/zig/zig-0.10.0.ebuild
@@ -21,7 +21,8 @@ SLOT="0"
BUILD_DIR="${S}/build"
-# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend (non-LLVM backends don't require these).
+# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend.
+# (non-LLVM backends don't require these)
# They are not required "on their own", so please don't add them here.
# You can check https://github.com/ziglang/zig-bootstrap in future, to see
# options that are passed to LLVM CMake building (excluding "static" ofc).
@@ -52,6 +53,9 @@ llvm_check_deps() {
pkg_setup() {
llvm_pkg_setup
+ ewarn "This version requires 10G of memory for building compiler."
+ ewarn "If you don't have enough memory, you can wait until 0.11.0 release"
+ ewarn "or (if you are risky) use 9999 version (currently requires only 4GB)"
check-reqs_pkg_setup
}
@@ -73,9 +77,10 @@ src_test() {
pkg_postinst() {
elog "0.10.0 release introduces self-hosted compiler for general use by default"
elog "It means that your code can be un-compilable since this compiler has some new or removed features and new or fixed bugs"
- elog "Upstream recommends using stage1 if experiencing such breakage,"
- elog "until bugfix release 0.10.1 or release 0.11.0 where old compiler will be fully replaced"
- elog "You can use old compiler by using '-fstage1' flag"
+ elog "Upstream recommends:"
+ elog " * Using old compiler if experiencing such breakage (flag '-fstage1')"
+ elog " * Waiting for bugfix release 0.10.1"
+ elog " * Waiting for release 0.11.0 with old compiler removed (these changes are already merged in 9999)"
elog "Also see: https://ziglang.org/download/0.10.0/release-notes.html#Self-Hosted-Compiler"
elog "and https://ziglang.org/download/0.10.0/release-notes.html#How-to-Upgrade"
}
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index a19a2873f8cd..04794281b8d8 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -21,7 +21,8 @@ SLOT="0"
BUILD_DIR="${S}/build"
-# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend (non-LLVM backends don't require these).
+# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend.
+# (non-LLVM backends don't require these)
# They are not required "on their own", so please don't add them here.
# You can check https://github.com/ziglang/zig-bootstrap in future, to see
# options that are passed to LLVM CMake building (excluding "static" ofc).
@@ -39,11 +40,9 @@ RDEPEND="
# see https://github.com/ziglang/zig/issues/3382
QA_FLAGS_IGNORED="usr/bin/zig"
-# see https://ziglang.org/download/0.10.0/release-notes.html#Self-Hosted-Compiler
-# 0.10.0 release - 9.6 GiB, since we use compiler written in C++ for bootstrapping
-# 0.11.0 release - ~2.8 GiB, since we will (at least according to roadmap) use self-hosted compiler
-# (transpiled to C via C backend) for bootstrapping
-CHECKREQS_MEMORY="10G"
+# Since commit https://github.com/ziglang/zig/commit/e7d28344fa3ee81d6ad7ca5ce1f83d50d8502118
+# Zig uses self-hosted compiler only
+CHECKREQS_MEMORY="4G"
llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"