summaryrefslogtreecommitdiff
path: root/dev-lang/zig-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-09 12:02:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-09 12:02:14 +0000
commit0fd62365fc104d7e6d5f3ef67800df09225a4019 (patch)
tree163b4a5055e07325ae1dc4f9bbbc2021ca1b6afa /dev-lang/zig-bin
parent442eaf1780a48ddbd7a39f5a3f34d959c3c6d27e (diff)
gentoo auto-resync : 09:03:2023 - 12:02:14
Diffstat (limited to 'dev-lang/zig-bin')
-rw-r--r--dev-lang/zig-bin/Manifest1
-rw-r--r--dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-lang/zig-bin/Manifest b/dev-lang/zig-bin/Manifest
index 577c09960112..cb11bad4c376 100644
--- a/dev-lang/zig-bin/Manifest
+++ b/dev-lang/zig-bin/Manifest
@@ -9,5 +9,6 @@ DIST zig-linux-riscv64-0.10.1.tar.xz 42196008 BLAKE2B a7ae37b1d1db1281b09bbd7e35
DIST zig-linux-x86_64-0.10.0.tar.xz 44142400 BLAKE2B 7ba72ce57e616c5ead2fb84dc7e1b0ff08e8dffab56ca30cd00bff1d9b80fd62034f3d78b903f37f911665239a4717a6e93230faa77b3f387b0dada835672fb7 SHA512 87037766e58a736d7e4f9fca1c21dce070f2de8cd08dae7951e67252327b72dd69f79831f5c8e406be7ecc6522184400eba3bd265d3c7020c8fa4d2efc9f8766
DIST zig-linux-x86_64-0.10.1.tar.xz 44085596 BLAKE2B d689a469dbbe790593a561dd4df01c506212754c48be7de03773c7e690cbab197af10d639e80148f3343204ddf9ecfe09a88a62fb6ef63a262bcc2dd79fecd34 SHA512 1cf88a492b1a47800e213b8801477f4ffabf269f960d27d1849c5aec805b5db3768c83d4daa4a738532b1b7367e8c6812e3eea47c205ea732d7a6269a47e16dc
EBUILD zig-bin-0.10.0.ebuild 1999 BLAKE2B 5f58d0fb901f1ddcbdd5939687ea4c3d5f6211198efebb0e215999f4156af2a1e76df3bffd7781f57579c2a3026bb8805b2dcc53863141b299155c0f9be08743 SHA512 449e70f2ba79903e6aa97d96260fced9cf2efb76e4a4b111e37c83de735662a7b7ef31d07a2da8b39995e6ab3c55f69aa53b5076fc80e5d2960eee70b60ad61f
+EBUILD zig-bin-0.10.1-r1.ebuild 2156 BLAKE2B fcb150895a2c080b332aed35b8b1edbb599fb2c0677c3d31c7f17721cd225feef773de671df1dc6ef85ba9acdccf7c0c2db4b3eebe3a5a2728342992369d5d43 SHA512 f1ed0b89fda56b2be26cd01c5066a8a8a315bc82d89ee1befd851d214d3c8b24b03d736206b2dcb8d58843452bc8d29b34762e0204d005affd60905dc579ab97
EBUILD zig-bin-0.10.1.ebuild 1978 BLAKE2B 88c315e88ebb5c3e4398709ed6c30f7ecc6e21d0975b99f3da59d362dd81690d509a08474ce19a07c76b37a94584c8e03d18cae9a395857ae8bfb50e1c8cad74 SHA512 e0d998899bb55576ad37b8d88c0a8e593a8361ffc43249d4f861f3546832d859ec61c203b914d49e8bce2a2a6c83f29836f459d1c191a9ce105714bfa904e0f4
MISC metadata.xml 541 BLAKE2B 6f5c7fbf759f0430f69073a17a0dae4b8bebf335b54c3b43da6b24104dc3de05a3b686cddbbd31e4dae1fc31695a2f08d000d22437ed6f1847de8fa95e3b1952 SHA512 d49cf0a8ad76ac9a6f6fb091effddbbcd812b56f91df6d3c782e15197cb4ff4423fb1076671a232aabcb9833af19ef8c820ad6df312a1e4d72e665680314c083
diff --git a/dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild b/dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..30514b6b713a
--- /dev/null
+++ b/dev-lang/zig-bin/zig-bin-0.10.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A robust, optimal, and maintainable programming language"
+HOMEPAGE="https://ziglang.org/"
+SRC_URI="
+ amd64? ( https://ziglang.org/download/${PV}/zig-linux-x86_64-${PV}.tar.xz )
+ arm? ( https://ziglang.org/download/${PV}/zig-linux-armv7a-${PV}.tar.xz )
+ arm64? ( https://ziglang.org/download/${PV}/zig-linux-aarch64-${PV}.tar.xz )
+ riscv? ( https://ziglang.org/download/${PV}/zig-linux-riscv64-${PV}.tar.xz )
+ x86? ( https://ziglang.org/download/${PV}/zig-linux-i386-${PV}.tar.xz )"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="app-eselect/eselect-zig"
+# Zig provides its standard library in source form "/opt/zig-bin-{PV}/lib/",
+# and all other Zig libraries are meant to be consumed in source form,
+# because they can use compile-time mechanics (and it is easier for distributions to patch them)
+# Here we use this feature for fixing programs that use standard library
+# Note: Zig build system is also part of standard library, so we can fix it too
+#PATCHES=( )
+
+QA_PREBUILT="opt/${P}/zig"
+
+src_unpack() {
+ unpack ${A}
+
+ mv "${WORKDIR}/"* "${S}" || die
+}
+
+src_install() {
+ insinto /opt/
+
+ use doc && local HTML_DOCS=( "doc/langref.html" "doc/std/" )
+ einstalldocs
+ rm -r ./doc/ || die
+
+ doins -r "${S}"
+ fperms 0755 "/opt/${P}/zig"
+ dosym -r "/opt/${P}/zig" "/usr/bin/zig-bin-${PV}"
+}
+
+pkg_postinst() {
+ eselect zig update ifunset
+
+ elog "0.10.1 release uses self-hosted compiler by default and fixes some bugs from 0.10.0"
+ elog "But your code still can be un-compilable since some features still not implemented or bugs not fixed"
+ elog "Upstream recommends:"
+ elog " * Using old compiler if experiencing such breakage (flag '-fstage1')"
+ elog " * Waiting for release 0.11.0 with old compiler removed (these changes are already merged in 9999)"
+ elog "Also see: https://ziglang.org/download/0.10.0/release-notes.html#Self-Hosted-Compiler"
+ elog "and https://ziglang.org/download/0.10.0/release-notes.html#How-to-Upgrade"
+}
+
+pkg_postrm() {
+ eselect zig update ifunset
+}