summaryrefslogtreecommitdiff
path: root/dev-lang/yasm/yasm-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 23:02:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 23:02:44 +0100
commitdb063b515939ab15261136b24e4bc44386335c0c (patch)
tree54c06cac96a32ba6fe5f69e52616a2ab27bbb6d6 /dev-lang/yasm/yasm-1.3.0.ebuild
parent8b4ace9c50842c5b83401ea7b179dcab940387e1 (diff)
gentoo resync : 24.09.2020
Diffstat (limited to 'dev-lang/yasm/yasm-1.3.0.ebuild')
-rw-r--r--dev-lang/yasm/yasm-1.3.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-lang/yasm/yasm-1.3.0.ebuild b/dev-lang/yasm/yasm-1.3.0.ebuild
deleted file mode 100644
index 7104a751fd07..000000000000
--- a/dev-lang/yasm/yasm-1.3.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 toolchain-funcs
-
-DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
-HOMEPAGE="http://yasm.tortall.net/"
-SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
-
-LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="-* amd64 ~arm64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="nls python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- nls? ( virtual/libintl )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
- python? ( $(python_gen_cond_dep '>=dev-python/cython-0.14[${PYTHON_USEDEP}]') )"
-
-pkg_setup() {
- : # Avoid python-single-r1_pkg_setup
-}
-
-src_configure() {
- use python && python_setup
-
- XMLTO=: \
- econf \
- CC_FOR_BUILD=$(tc-getBUILD_CC) \
- CCLD_FOR_BUILD=$(tc-getBUILD_CC) \
- $(use_enable python) \
- $(use_enable python python-bindings) \
- $(use_enable nls)
-}
-
-src_test() {
- # https://bugs.gentoo.org/718870
- emake -j1 check
-}