summaryrefslogtreecommitdiff
path: root/dev-lang/typescript/typescript-5.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-20 23:10:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-20 23:10:12 +0000
commit3efb3c04b80206d986b51767e6b879119d219e42 (patch)
tree1dc83a1d5ba52b1e6b3e792ea1dae4f9e7353186 /dev-lang/typescript/typescript-5.3.2.ebuild
parentbe675f929577458bd306c90ed78b62054197c0b1 (diff)
gentoo auto-resync : 20:11:2023 - 23:10:12
Diffstat (limited to 'dev-lang/typescript/typescript-5.3.2.ebuild')
-rw-r--r--dev-lang/typescript/typescript-5.3.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/typescript/typescript-5.3.2.ebuild b/dev-lang/typescript/typescript-5.3.2.ebuild
new file mode 100644
index 000000000000..598301d43b33
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}