summaryrefslogtreecommitdiff
path: root/dev-lang/tcc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-lang/tcc
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-lang/tcc')
-rw-r--r--dev-lang/tcc/Manifest4
-rw-r--r--dev-lang/tcc/tcc-0.9.27_p20211022.ebuild86
-rw-r--r--dev-lang/tcc/tcc-9999.ebuild53
3 files changed, 122 insertions, 21 deletions
diff --git a/dev-lang/tcc/Manifest b/dev-lang/tcc/Manifest
index 2663798b148d..cca317187310 100644
--- a/dev-lang/tcc/Manifest
+++ b/dev-lang/tcc/Manifest
@@ -1,4 +1,6 @@
DIST tcc-0.9.27.tar.bz2 634999 BLAKE2B 9a76dac9f54fa0b64a72e874cfec9a4bd9b938d244d064b2e76bd31acfb9e48fdbdb8895132634be1dee4302293405bf75606a6804c8178afa8fd30daa53b73a SHA512 835184292d97c07f0ff7b36ec550e855e649b04e23c7e2a1c706d223409eb60708dc1ae969f28eba45e56c8b96ae56936b93caf9d8a13ac5adf119014d5367a7
+DIST tcc-0.9.27_p20211022.tar.gz 893631 BLAKE2B f1a82498db65a9944f04a6c35897db6ceeea0e5d14ac383acc6b334fb2aa921a0e7b4badf647c101d064ceae1ee8d79ab91674a2d0faa2899b831a57e6148174 SHA512 5f40a0d31d63e876d1fb233758d9f58be2f14807bbc0847b7df3eb6bb8df0946100b58edb5a29caea8770201d02275daf0a3ca7668141151e931204ad7100fb3
EBUILD tcc-0.9.27.ebuild 1507 BLAKE2B 463216d8345068c8852fc76571f7db26722813c05efbfaad2372b950d8344ece98c3452ff87899ff4e8616ed51c3df76a6fd6aa0ff53f40f2b363393eec50c67 SHA512 94bd0fe005b456f96e8c8da642d02a1cb6d2005aca0e1e1530e3167f85c50cb017c9849b391dfdc870da1e72da14206cecd6897833cd68cc111543014b06e8ce
-EBUILD tcc-9999.ebuild 1705 BLAKE2B cdb32188eee6371e7f05579ee723bd2034428d6869a151f82a6576db15e32e8252d181a5d51a059b3062453f6c42a850d707c497986fb2156b7dbca703b08284 SHA512 90bf09da8190441b439148cd642b0082bc69ce3593f58b3a60bb62111234aec12694f5d90c99bb80d984182053158597a64ae6aaa50d6406fb60a76375d73406
+EBUILD tcc-0.9.27_p20211022.ebuild 2040 BLAKE2B 4c7ba161c9fc674a69ff15137ff92ceb5a8410f31e203f9783762751a06bf86dfedcd1eed91b582323e1a7b4d02342d74778da2773a0fc09f6046332b72de1b5 SHA512 aee75cbede5d69917c9ddbe1a55990d76f458cf06db6cbb60e96fa9e3f876a734535630503a62e86a901d32ba90652d3883d09075cb824875230d476ecd8abbc
+EBUILD tcc-9999.ebuild 2040 BLAKE2B 4c7ba161c9fc674a69ff15137ff92ceb5a8410f31e203f9783762751a06bf86dfedcd1eed91b582323e1a7b4d02342d74778da2773a0fc09f6046332b72de1b5 SHA512 aee75cbede5d69917c9ddbe1a55990d76f458cf06db6cbb60e96fa9e3f876a734535630503a62e86a901d32ba90652d3883d09075cb824875230d476ecd8abbc
MISC metadata.xml 241 BLAKE2B ac22a6a72982cebf268e9d367947dc556420370c70b1f6e26531950f7f2c89734cd293fad93dfea0345fd020a97b8f9304c1362a2ccd6225b22aac1f7b674b17 SHA512 b59cc421f52bc545bc8667dcbf6b4891e29180ef1984596ccc20886071e5f080bed259026c2831c6418131802b93ad945137fe4406d042feb02d9bfdc14c431c
diff --git a/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild b/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild
new file mode 100644
index 000000000000..6d4133762683
--- /dev/null
+++ b/dev-lang/tcc/tcc-0.9.27_p20211022.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_COMMIT="16456168430c9e185dd94b8215aa77d02bbb8a2c"
+DESCRIPTION="A very small C compiler for ix86/amd64"
+HOMEPAGE="https://bellard.org/tcc/ https://repo.or.cz/tinycc.git/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://repo.or.cz/r/tinycc.git"
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ SRC_URI="https://repo.or.cz/tinycc.git/snapshot/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/tinycc-1645616
+else
+ SRC_URI="https://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
+
+BDEPEND="dev-lang/perl" # doc generation
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+
+ # Don't strip
+ sed -i \
+ -e 's|$(INSTALL) -s|$(INSTALL)|' \
+ -e 's|STRIP_yes = -s|STRIP_yes =|' \
+ Makefile || die
+
+ # Fix examples
+ sed -i -e '1{
+ i#! /usr/bin/tcc -run
+ /^#!/d
+ }' examples/ex*.c || die
+ sed -i -e '1s/$/ -lX11/' examples/ex4.c || die
+
+ # Fix texi2html invocation
+ sed -i -e 's/-number//' Makefile || die
+ sed -i -e 's/--sections//' Makefile || die
+}
+
+src_configure() {
+ local libc
+
+ use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
+ # better fixes welcome, it feels wrong to hack the env like this
+
+ use elibc_musl && libc=musl
+ use elibc_uclibc && libc=uClibc
+
+ # not autotools, so call configure directly
+ ./configure --cc="$(tc-getCC)" \
+ ${libc:+--config-${libc}} \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ # this is using tcc bits that don't know as-needed etc.
+ TCCFLAGS="" emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc Changelog README TODO VERSION
+ #dohtml tcc-doc.html
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/ex*.c
+}
diff --git a/dev-lang/tcc/tcc-9999.ebuild b/dev-lang/tcc/tcc-9999.ebuild
index 5aa530ef3af5..6d4133762683 100644
--- a/dev-lang/tcc/tcc-9999.ebuild
+++ b/dev-lang/tcc/tcc-9999.ebuild
@@ -1,34 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
+inherit toolchain-funcs
+
+MY_COMMIT="16456168430c9e185dd94b8215aa77d02bbb8a2c"
DESCRIPTION="A very small C compiler for ix86/amd64"
-HOMEPAGE="https://bellard.org/tcc/"
+HOMEPAGE="https://bellard.org/tcc/ https://repo.or.cz/tinycc.git/"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://repo.or.cz/r/tinycc.git"
- SRC_URI=""
- scm_eclass=git-r3
+ inherit git-r3
+elif [[ ${PV} == *_p* ]] ; then
+ SRC_URI="https://repo.or.cz/tinycc.git/snapshot/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/tinycc-1645616
else
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
SRC_URI="https://download.savannah.gnu.org/releases/tinycc/${P}.tar.bz2"
fi
-inherit toolchain-funcs ${scm_eclass}
-
LICENSE="LGPL-2.1"
SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
-DEPEND="dev-lang/perl" # doc generation
-# Both tendra and tinycc install /usr/bin/tcc
-RDEPEND="!dev-lang/tendra"
+BDEPEND="dev-lang/perl" # doc generation
IUSE="test"
RESTRICT="!test? ( test )"
src_prepare() {
+ default
+
# Don't strip
- sed -i -e 's|$(INSTALL) -s|$(INSTALL)|' Makefile || die
+ sed -i \
+ -e 's|$(INSTALL) -s|$(INSTALL)|' \
+ -e 's|STRIP_yes = -s|STRIP_yes =|' \
+ Makefile || die
# Fix examples
sed -i -e '1{
@@ -37,25 +45,35 @@ src_prepare() {
}' examples/ex*.c || die
sed -i -e '1s/$/ -lX11/' examples/ex4.c || die
- # fix texi2html invocation
+ # Fix texi2html invocation
sed -i -e 's/-number//' Makefile || die
sed -i -e 's/--sections//' Makefile || die
-
- eapply_user
}
src_configure() {
+ local libc
+
use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise
# better fixes welcome, it feels wrong to hack the env like this
+
+ use elibc_musl && libc=musl
+ use elibc_uclibc && libc=uClibc
+
# not autotools, so call configure directly
./configure --cc="$(tc-getCC)" \
+ ${libc:+--config-${libc}} \
--prefix="${EPREFIX}/usr" \
--libdir="${EPREFIX}/usr/$(get_libdir)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}"
}
src_compile() {
- emake AR="$(tc-getAR)"
+ emake AR="$(tc-getAR)" LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ # this is using tcc bits that don't know as-needed etc.
+ TCCFLAGS="" emake test
}
src_install() {
@@ -66,8 +84,3 @@ src_install() {
exeinto /usr/share/doc/${PF}/examples
doexe examples/ex*.c
}
-
-src_test() {
- # this is using tcc bits that don't know as-needed etc.
- TCCFLAGS="" emake test
-}