summaryrefslogtreecommitdiff
path: root/dev-lang/smlnj/smlnj-110.99.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /dev-lang/smlnj/smlnj-110.99.2.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'dev-lang/smlnj/smlnj-110.99.2.ebuild')
-rw-r--r--dev-lang/smlnj/smlnj-110.99.2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/smlnj/smlnj-110.99.2.ebuild b/dev-lang/smlnj/smlnj-110.99.2.ebuild
index 98c8b3ecdf06..247d06dc4ca7 100644
--- a/dev-lang/smlnj/smlnj-110.99.2.ebuild
+++ b/dev-lang/smlnj/smlnj-110.99.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -84,10 +84,10 @@ src_prepare() {
default
# respect CC et al. (bug 243886)
- sed -e "/^AS/s:as:$(tc-getAS):" \
- -e "/^CC/s:gcc:$(tc-getCC):" \
- -e "/^CPP/s:gcc:$(tc-getCC):" \
- -e "/^CFLAGS/{s:-O[0123s]:: ; s:=:= ${CFLAGS}:}" \
+ sed -e "/^AS/s|as|$(tc-getAS)|" \
+ -e "/^CC/s|gcc|$(tc-getCC)|" \
+ -e "/^CPP/s|gcc|$(tc-getCC)|" \
+ -e "/^CFLAGS/{s|-O[0123s]|| ; s|=|= ${CFLAGS}|}" \
-i base/runtime/objs/mk.* || die
sed -i "s|nm |$(tc-getNM) |g" config/chk-global-names.sh || die
@@ -109,7 +109,7 @@ src_install() {
for file in bin/{*,.*} ; do
[[ -f ${file} ]] &&
sed -e "2iSMLNJ_HOME=${EPREFIX}/${DIR}" \
- -e "s:${WORKDIR}:${EPREFIX}/${DIR}:" \
+ -e "s|${WORKDIR}|${EPREFIX}/${DIR}|" \
-i ${file}
done