summaryrefslogtreecommitdiff
path: root/dev-lang/qore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-24 11:22:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-24 11:22:25 +0100
commit6a851e4f7c23c15c4b7853e6c34b0a0b9bc68482 (patch)
tree027421c2b8ddbc8c802c488ba086753da35fcfad /dev-lang/qore
parentfcf991edcc1b310199e4e829a3706bc1c267d1db (diff)
gentoo auto-resync : 24:09:2023 - 11:22:25
Diffstat (limited to 'dev-lang/qore')
-rw-r--r--dev-lang/qore/Manifest3
-rw-r--r--dev-lang/qore/metadata.xml23
-rw-r--r--dev-lang/qore/qore-1.19.0.ebuild72
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-lang/qore/Manifest b/dev-lang/qore/Manifest
new file mode 100644
index 000000000000..063ffcb8e2ea
--- /dev/null
+++ b/dev-lang/qore/Manifest
@@ -0,0 +1,3 @@
+DIST qore-1.19.0.tar.gz 3932880 BLAKE2B 8987a818e4fef495d9e07477715f18ad70541c81108bbc3aac56660e4d2ee9349303654ba07a849a7bfb43952d0ee8b868224f029254c83f435aa024def08669 SHA512 5264db098644ba39316e7825f1ed8243240c506a22c15836fcfa9500b173807ee9c4d213577d3a9eee7220d5d15ad171f05f75a431fb0537c95ab3dc761cbba3
+EBUILD qore-1.19.0.ebuild 1269 BLAKE2B 02ecd5f0da47fb5188de0f38105d11db9bb7c41741134778858f9d1196ed45e68242e9ec9f17b1aa6bdc0450dc49b8ab6b960659cb4c2f402cca345ff4524791 SHA512 d4d2c02419681293bf8e91034bddd64015cedc76c1df223cd4d86c24e0821ec5c1d829a54d3498aef6da50f344178bba8e70e2acb0342bd354039ed93e56ee2a
+MISC metadata.xml 988 BLAKE2B 3a74a6ca601e603b3fd02afac98ac66a2918537ad2c2d44620a2bf458a246c9c0e26bd733a5af26b7baca9c3bd69949f0ae7332bf5efbc184a3714580c545322 SHA512 39372b45ba7b12127a355ced7e18b2c537bd09127e0db503fb0e3dbb3584f2095a77f69f000473451ce73b0f1dc38243478d34312def725c9936c49485607638
diff --git a/dev-lang/qore/metadata.xml b/dev-lang/qore/metadata.xml
new file mode 100644
index 000000000000..f623d113a866
--- /dev/null
+++ b/dev-lang/qore/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ The Qore programming language is a powerful, thread-capable, embeddable
+ weakly-typed language with optional strong typing and procedural and
+ object-oriented features designed for anything from quick scripting to
+ complex multithreaded, network-aware application development to embedded
+ application scripting. Qore was initially designed to facilitate the rapid
+ implementation of sophisticated interfaces in embedded code in an
+ enterprise environment, and has since grown into a general-purpose language
+ as well.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/qorelanguage/qore/issues</bugs-to>
+ <remote-id type="github">qorelanguage/qore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lang/qore/qore-1.19.0.ebuild b/dev-lang/qore/qore-1.19.0.ebuild
new file mode 100644
index 000000000000..5ca2ae1bc341
--- /dev/null
+++ b/dev-lang/qore/qore-1.19.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Qore, the embeddable multithreaded scripting language"
+HOMEPAGE="http://qore.org/
+ https://github.com/qorelanguage/qore/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/qorelanguage/${PN}.git"
+else
+ SRC_URI="https://github.com/qorelanguage/${PN}/archive/release-${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-release-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+ MIT"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-libs/libpcre:=
+ dev-libs/mpfr:=
+ dev-libs/openssl:=
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local -a myconf=(
+ --disable-optimization
+ --disable-profile
+ --disable-static-bz2
+ --disable-static-common
+ --disable-static-openssl
+ --disable-static-pcre
+ --disable-static-zlib
+ $(use_enable debug)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ PATH="${S}:${PATH}" emake check
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete ||
+ die "failed to remove libtool files without corresponding static libraries"
+}