summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.7.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-lang/python/python-3.7.11.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-lang/python/python-3.7.11.ebuild')
-rw-r--r--dev-lang/python/python-3.7.11.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-lang/python/python-3.7.11.ebuild b/dev-lang/python/python-3.7.11.ebuild
index 1cfc503ae0f0..2a194aeea941 100644
--- a/dev-lang/python/python-3.7.11.ebuild
+++ b/dev-lang/python/python-3.7.11.ebuild
@@ -58,7 +58,6 @@ BDEPEND="
virtual/pkgconfig
verify-sig? ( app-crypt/openpgp-keys-python )
!sys-devel/gcc[libffi(-)]"
-PDEPEND="app-eselect/eselect-python"
RDEPEND+=" !build? ( app-misc/mime-types )"
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/python.org.asc
@@ -175,7 +174,7 @@ src_compile() {
emake CPPFLAGS= CFLAGS= LDFLAGS=
# Work around bug 329499. See also bug 413751 and 457194.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E python
else
pax-mark m python
@@ -254,7 +253,7 @@ src_install() {
# python seems to get rebuilt in src_install (bug 569908)
# Work around it for now.
- if has_version dev-libs/libffi[pax_kernel]; then
+ if has_version dev-libs/libffi[pax-kernel]; then
pax-mark E "${ED}/usr/bin/${abiver}"
else
pax-mark m "${ED}/usr/bin/${abiver}"