summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.13.0_alpha2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-26 19:38:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-26 19:38:09 +0000
commit7ab79528a3e9a77497eb58022bb0e775e7440885 (patch)
tree10bac8ed3339f6c09a7afc5111ff705b708831d1 /dev-lang/python/python-3.13.0_alpha2.ebuild
parentc25546f65119d2fb9a2f79588fd130d62989eddb (diff)
gentoo auto-resync : 26:12:2023 - 19:38:09
Diffstat (limited to 'dev-lang/python/python-3.13.0_alpha2.ebuild')
-rw-r--r--dev-lang/python/python-3.13.0_alpha2.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-lang/python/python-3.13.0_alpha2.ebuild b/dev-lang/python/python-3.13.0_alpha2.ebuild
index b2364be2514c..e38ba4022735 100644
--- a/dev-lang/python/python-3.13.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.13.0_alpha2.ebuild
@@ -29,7 +29,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}"
IUSE="
- bluetooth build debug +ensurepip examples gdbm libedit lto
+ bluetooth build debug +ensurepip examples gdbm libedit
+ncurses pgo +readline +sqlite +ssl test tk valgrind
"
RESTRICT="!test? ( test )"
@@ -201,7 +201,6 @@ build_cbuild_python() {
}
src_configure() {
- local disable
# disable automagic bluetooth headers detection
if ! use bluetooth; then
local -x ac_cv_header_bluetooth_bluetooth_h=no
@@ -210,11 +209,6 @@ src_configure() {
append-flags -fwrapv
filter-flags -malign-double
- # https://bugs.gentoo.org/700012
- if is-flagq -flto || is-flagq '-flto=*'; then
- append-cflags $(test-flags-CC -ffat-lto-objects)
- fi
-
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
@@ -278,17 +272,26 @@ src_configure() {
--with-libc=
--enable-loadable-sqlite-extensions
--without-ensurepip
+ --without-lto
--with-system-expat
--with-platlibdir=lib
--with-pkg-config=yes
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
$(use_with debug assertions)
- $(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
$(use_with valgrind)
)
+
+ # https://bugs.gentoo.org/700012
+ if tc-is-lto; then
+ append-cflags $(test-flags-CC -ffat-lto-objects)
+ myeconfargs+=(
+ --with-lto
+ )
+ fi
+
# Force-disable modules we don't want built.
# See Modules/Setup for docs on how this works. Setup.local contains our local deviations.
cat > Modules/Setup.local <<-EOF || die