summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.11.0_p2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 13:08:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 13:08:35 +0000
commit87cdf8e64e5874146493d2a4a4489b08583043c3 (patch)
treeb481dca3db38189f893c7e9fdf3fb98731b097a9 /dev-lang/python/python-3.11.0_p2.ebuild
parentbed152ba1fc2f1316eaefb5c3d24d48195560f76 (diff)
gentoo auto-resync : 23:11:2022 - 13:08:35
Diffstat (limited to 'dev-lang/python/python-3.11.0_p2.ebuild')
-rw-r--r--dev-lang/python/python-3.11.0_p2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.11.0_p2.ebuild b/dev-lang/python/python-3.11.0_p2.ebuild
index 34cae611b846..eedf9c768a85 100644
--- a/dev-lang/python/python-3.11.0_p2.ebuild
+++ b/dev-lang/python/python-3.11.0_p2.ebuild
@@ -31,7 +31,7 @@ SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
bluetooth build +ensurepip examples gdbm hardened libedit lto
- +ncurses pgo +readline +sqlite +ssl test tk
+ +ncurses pgo +readline +sqlite +ssl test tk valgrind
"
RESTRICT="!test? ( test )"
@@ -72,6 +72,7 @@ DEPEND="
${RDEPEND}
bluetooth? ( net-wireless/bluez )
test? ( app-arch/xz-utils[extra-filters(+)] )
+ valgrind? ( dev-util/valgrind )
"
# autoconf-archive needed to eautoreconf
BDEPEND="
@@ -211,6 +212,7 @@ src_configure() {
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
+ $(use_with valgrind)
)
# disable implicit optimization/debugging flags