summaryrefslogtreecommitdiff
path: root/dev-lang/python/files/3.6-disable-nis.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-12 16:49:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-12 16:49:02 +0000
commit519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (patch)
tree7e99d88a777fe8c9d3ec6310bf7eea639b0e66b4 /dev-lang/python/files/3.6-disable-nis.patch
parenta5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (diff)
gentoo resync : 12.11.2017
Diffstat (limited to 'dev-lang/python/files/3.6-disable-nis.patch')
-rw-r--r--dev-lang/python/files/3.6-disable-nis.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-lang/python/files/3.6-disable-nis.patch b/dev-lang/python/files/3.6-disable-nis.patch
new file mode 100644
index 000000000000..4e81847b5070
--- /dev/null
+++ b/dev-lang/python/files/3.6-disable-nis.patch
@@ -0,0 +1,21 @@
+--- a/setup.py
++++ b/setup.py
+@@ -1332,17 +1332,7 @@ class PyBuildExt(build_ext):
+ # Jeremy Hylton's rlimit interface
+ exts.append( Extension('resource', ['resource.c']) )
+
+- # Sun yellow pages. Some systems have the functions in libc.
+- if (host_platform not in ['cygwin', 'qnx6'] and
+- find_file('rpcsvc/yp_prot.h', inc_dirs, []) is not None):
+- if (self.compiler.find_library_file(lib_dirs, 'nsl')):
+- libs = ['nsl']
+- else:
+- libs = []
+- exts.append( Extension('nis', ['nismodule.c'],
+- libraries = libs) )
+- else:
+- missing.append('nis')
++ missing.append('nis')
+ else:
+ missing.extend(['nis', 'resource', 'termios'])
+