summaryrefslogtreecommitdiff
path: root/dev-lang/python-exec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 01:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 01:47:04 +0000
commit8bb75334c4b9f91e9f95784e986ed31b4bc11f92 (patch)
tree8abc434e6b84ebe89eee2e7ae9687354cdf8d2c8 /dev-lang/python-exec
parentf74222a7b6daa24caf124c66a7ce05c7ea773b08 (diff)
gentoo auto-resync : 19:12:2022 - 01:47:04
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/Manifest2
-rw-r--r--dev-lang/python-exec/python-exec-2.4.9.ebuild72
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-lang/python-exec/Manifest b/dev-lang/python-exec/Manifest
index 2e308bac48a5..dc80ba59112b 100644
--- a/dev-lang/python-exec/Manifest
+++ b/dev-lang/python-exec/Manifest
@@ -1,5 +1,3 @@
DIST python-exec-2.4.10.tar.bz2 84412 BLAKE2B 1fe79e0d31a48954959a5556f96c3868fcf762ebc473d17f03e78a95cca83ab40b4933b7e42bc5751b0546e6229f9fdde9171c3fcbdd184f993536f944870491 SHA512 8c7d3c6b1fa362c8c97ec74ee01b5a195dc409d883408033e9709773b6059deb5291f6e63df6d9a4e42a0951aad4a1d513d4baa00ad9ff3dce3e1d2d38b694e1
-DIST python-exec-2.4.9.tar.bz2 84300 BLAKE2B 77ad193f2602db392830eb4e2632562cfa1ca09bdc710e35dc141a036230ac21e63a51d297184740d85e6c3be8cb4b7ffefef270e51533ff15250f474437a52e SHA512 ad520dc7724bc71629e238226cd795214860e0a090a065dc85f782e6bd86c30ba46d58cb80d46221f4ff4a146332244b6670335a8f31f630088f477588ed8293
EBUILD python-exec-2.4.10.ebuild 2008 BLAKE2B 44918788dbf080a2e8380635c56b0416a41e389419260387847b57fd9f3ff00f68e0a10fd1076f6158bcf355bf43d1373e81465b08ff47bec1abd1bad2e5ec9c SHA512 82698efb94d27ccc18f20c523d207befae8cb2f7bc5475b8a1b622669c3557a2c0a3fdfd6698cf647802160e48423a9ab9a76f81edb8d34befd80a5c44fab800
-EBUILD python-exec-2.4.9.ebuild 2001 BLAKE2B 7fa42527d3b5693a1dcd2a83c05ad1e0a1995616c68a6d1bd59593ff67fb8d69a2a0966adc85aae73c8d156e291b0279edccecfa6ba85bbace8f6b85e1f58399 SHA512 a1953a4481fec91f0556919a90729ac5195a33e4ded0014a14fbbdeb2b7092806513479726d38a5fe389cfc302f6408c0820a8a40c85c947e9047f8a76a9870e
MISC metadata.xml 792 BLAKE2B 523252765f0c1aeb4986e5f2acae02959e040cb7f9586f3b4391db730e1fcee3297dafbf05850cf2a6cbce34ab5168bbc965c2dd680b240f944b8199013ad914 SHA512 da707d555bc3f0c2d70a1fe3700c427091c3ca5e12c812714d5f3e13a518b5986bfd6a219820e35223e848e88098df81f5e4c80de33146ee3b273048e83c0521
diff --git a/dev-lang/python-exec/python-exec-2.4.9.ebuild b/dev-lang/python-exec/python-exec-2.4.9.ebuild
deleted file mode 100644
index 4fd31fa50604..000000000000
--- a/dev-lang/python-exec/python-exec-2.4.9.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-inherit python-any-r1
-
-DESCRIPTION="Python script wrapper"
-HOMEPAGE="https://github.com/mgorny/python-exec/"
-SRC_URI="https://github.com/mgorny/python-exec/releases/download/v${PV}/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-# Internal Python project hack. Do not copy it. Ever.
-IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_} +native-symlinks test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lang/python-exec-conf
- !<=dev-lang/python-2.7.18-r3:2.7"
-BDEPEND="
- test? (
- $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
- )"
-
-python_check_deps() {
- has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local pyimpls=() i EPYTHON
- for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- _python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
- fi
- done
-
- local myconf=(
- --with-fallback-path="${EPREFIX}/usr/local/sbin:${EPREFIX}/usr/local/bin:${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin"
- --with-python-impls="${pyimpls[*]}"
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- if use native-symlinks; then
- local programs=( python python3 )
- local scripts=( python-config python3-config 2to3 idle pydoc pyvenv )
-
- local f
- for f in "${programs[@]}"; do
- # symlink the C wrapper for python to avoid shebang recursion
- # bug #568974
- dosym python-exec2c /usr/bin/"${f}"
- done
- for f in "${scripts[@]}"; do
- # those are python scripts (except for new python-configs)
- # so symlink them via the python wrapper
- dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
- done
- fi
-}