summaryrefslogtreecommitdiff
path: root/dev-lang/python-exec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-lang/python-exec
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/Manifest4
-rw-r--r--dev-lang/python-exec/python-exec-2.4.8.ebuild72
-rw-r--r--dev-lang/python-exec/python-exec-2.4.9.ebuild4
3 files changed, 3 insertions, 77 deletions
diff --git a/dev-lang/python-exec/Manifest b/dev-lang/python-exec/Manifest
index 1b2af063fd44..ce5b0df840bc 100644
--- a/dev-lang/python-exec/Manifest
+++ b/dev-lang/python-exec/Manifest
@@ -1,5 +1,3 @@
-DIST python-exec-2.4.8.tar.bz2 82671 BLAKE2B ac85f3dd6da3d1c535ad56a25edbbcb1d0e75b91e3567b80f27fd01d32a199a713909a8552dffaacbe96c43bca491f31c3f0c7f1a618fb9144814365686715cf SHA512 d6dabab217dc2f1817e2f4d159102a9467f51b26b91f4ae7fb7e4930d30334f74bd8a5f37cc60d58c6e1e61e89a3b4d2e1bd17413493ba86f38fa71250cf5ac1
DIST python-exec-2.4.9.tar.bz2 84300 BLAKE2B 77ad193f2602db392830eb4e2632562cfa1ca09bdc710e35dc141a036230ac21e63a51d297184740d85e6c3be8cb4b7ffefef270e51533ff15250f474437a52e SHA512 ad520dc7724bc71629e238226cd795214860e0a090a065dc85f782e6bd86c30ba46d58cb80d46221f4ff4a146332244b6670335a8f31f630088f477588ed8293
-EBUILD python-exec-2.4.8.ebuild 2001 BLAKE2B 7fa42527d3b5693a1dcd2a83c05ad1e0a1995616c68a6d1bd59593ff67fb8d69a2a0966adc85aae73c8d156e291b0279edccecfa6ba85bbace8f6b85e1f58399 SHA512 a1953a4481fec91f0556919a90729ac5195a33e4ded0014a14fbbdeb2b7092806513479726d38a5fe389cfc302f6408c0820a8a40c85c947e9047f8a76a9870e
-EBUILD python-exec-2.4.9.ebuild 2009 BLAKE2B 976055b15a474c531fbc2b3d306b1cc0362cf8189ac3293fa616e2e9aa0e9c3ccb9b6a881ddda3796b46814aefc60bf8aede49e828519c4c30d9c46aa52a195d SHA512 258d308a42a3755e2b885354ea310ea1b5791cac49e99ed5147025d32f1e721fa1c8e456680ef241b46f66791437a5ef03c079cf7919d791bb542a6511660787
+EBUILD python-exec-2.4.9.ebuild 2001 BLAKE2B 7fa42527d3b5693a1dcd2a83c05ad1e0a1995616c68a6d1bd59593ff67fb8d69a2a0966adc85aae73c8d156e291b0279edccecfa6ba85bbace8f6b85e1f58399 SHA512 a1953a4481fec91f0556919a90729ac5195a33e4ded0014a14fbbdeb2b7092806513479726d38a5fe389cfc302f6408c0820a8a40c85c947e9047f8a76a9870e
MISC metadata.xml 792 BLAKE2B 7358e3a57f7b55a2d166128d677d12bd29ab3b439b29b85fabbb28b0850d0d061f663817b422358d5effa8756bfe981099fdc096141add3058064d3e350f095a SHA512 a20e0c4bb1bae472324c3854295e6ab77d83cfbc816dc82f8d6b07b61beaddb61c67229fc0627675ce08e65363e1a916b73ee6be2419265b4a10a79f9bc7c621
diff --git a/dev-lang/python-exec/python-exec-2.4.8.ebuild b/dev-lang/python-exec/python-exec-2.4.8.ebuild
deleted file mode 100644
index 4fd31fa50604..000000000000
--- a/dev-lang/python-exec/python-exec-2.4.8.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-inherit python-any-r1
-
-DESCRIPTION="Python script wrapper"
-HOMEPAGE="https://github.com/mgorny/python-exec/"
-SRC_URI="https://github.com/mgorny/python-exec/releases/download/v${PV}/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-# Internal Python project hack. Do not copy it. Ever.
-IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_} +native-symlinks test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lang/python-exec-conf
- !<=dev-lang/python-2.7.18-r3:2.7"
-BDEPEND="
- test? (
- $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
- )"
-
-python_check_deps() {
- has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local pyimpls=() i EPYTHON
- for i in "${_PYTHON_ALL_IMPLS[@]}"; do
- if use "python_targets_${i}"; then
- _python_export "${i}" EPYTHON
- pyimpls+=( "${EPYTHON}" )
- fi
- done
-
- local myconf=(
- --with-fallback-path="${EPREFIX}/usr/local/sbin:${EPREFIX}/usr/local/bin:${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin"
- --with-python-impls="${pyimpls[*]}"
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- if use native-symlinks; then
- local programs=( python python3 )
- local scripts=( python-config python3-config 2to3 idle pydoc pyvenv )
-
- local f
- for f in "${programs[@]}"; do
- # symlink the C wrapper for python to avoid shebang recursion
- # bug #568974
- dosym python-exec2c /usr/bin/"${f}"
- done
- for f in "${scripts[@]}"; do
- # those are python scripts (except for new python-configs)
- # so symlink them via the python wrapper
- dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
- done
- fi
-}
diff --git a/dev-lang/python-exec/python-exec-2.4.9.ebuild b/dev-lang/python-exec/python-exec-2.4.9.ebuild
index d85ad8f0df6c..4fd31fa50604 100644
--- a/dev-lang/python-exec/python-exec-2.4.9.ebuild
+++ b/dev-lang/python-exec/python-exec-2.4.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit python-any-r1
DESCRIPTION="Python script wrapper"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/mgorny/python-exec/releases/download/v${PV}/${P}.tar
LICENSE="BSD-2"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# Internal Python project hack. Do not copy it. Ever.
IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_} +native-symlinks test"
RESTRICT="!test? ( test )"