summaryrefslogtreecommitdiff
path: root/dev-lang/python-exec/python-exec-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-lang/python-exec/python-exec-9999.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-lang/python-exec/python-exec-9999.ebuild')
-rw-r--r--dev-lang/python-exec/python-exec-9999.ebuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/dev-lang/python-exec/python-exec-9999.ebuild b/dev-lang/python-exec/python-exec-9999.ebuild
index c0f5a62b4d0b..f5c7a17a180b 100644
--- a/dev-lang/python-exec/python-exec-9999.ebuild
+++ b/dev-lang/python-exec/python-exec-9999.ebuild
@@ -1,15 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# Kids, don't do this at home!
-inherit python-utils-r1
-PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
-
-# Inherited purely to have PYTHON_TARGET flags which will satisfy USE
-# dependencies and trigger necessary rebuilds.
-inherit autotools git-r3 python-r1
+inherit autotools git-r3 python-utils-r1
DESCRIPTION="Python script wrapper"
HOMEPAGE="https://github.com/mgorny/python-exec/"
@@ -19,7 +13,8 @@ EGIT_REPO_URI="https://github.com/mgorny/python-exec.git"
LICENSE="BSD-2"
SLOT="2"
KEYWORDS=""
-IUSE=""
+# Internal Python project hack. Do not copy it. Ever.
+IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_}"
# eselect-python because of /usr/bin/python* collisions and new config
# python versions because of missing $scriptdir/python* symlinks
@@ -37,7 +32,7 @@ src_prepare() {
src_configure() {
local pyimpls=() i EPYTHON
- for i in "${PYTHON_COMPAT[@]}"; do
+ for i in "${_PYTHON_ALL_IMPLS[@]}"; do
python_export "${i}" EPYTHON
pyimpls+=( "${EPYTHON}" )
done
@@ -72,14 +67,14 @@ src_install() {
}
pkg_preinst() {
- if [[ -e ${EROOT}etc/python-exec/python-exec.conf ]]; then
+ if [[ -e ${EROOT}/etc/python-exec/python-exec.conf ]]; then
# preserve current configuration
- cp "${EROOT}"etc/python-exec/python-exec.conf \
- "${ED}"etc/python-exec/python-exec.conf || die
+ cp "${EROOT}"/etc/python-exec/python-exec.conf \
+ "${ED}"/etc/python-exec/python-exec.conf || die
else
# preserve previous Python version preference
local py old_pythons=()
- local config_base=${EROOT}etc/env.d/python
+ local config_base=${EROOT}/etc/env.d/python
# start with the 'global' preference (2 vs 3)
if [[ -f ${config_base}/config ]]; then
@@ -126,14 +121,14 @@ pkg_preinst() {
elog "you may want to modify the preference list yourself. In order to do so,"
elog "open the following file in your favorite editor:"
elog
- elog " ${EROOT}etc/python-exec/python-exec.conf"
+ elog " ${EROOT}/etc/python-exec/python-exec.conf"
elog
elog "For more information on the new configuration format, please read"
elog "the comment on top of the installed configuration file."
local IFS=$'\n'
echo "${old_pythons[*]}" \
- >> "${ED}"etc/python-exec/python-exec.conf || die
+ >> "${ED}"/etc/python-exec/python-exec.conf || die
fi
fi
}