summaryrefslogtreecommitdiff
path: root/dev-lang/perl/perl-5.30.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-lang/perl/perl-5.30.0.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-lang/perl/perl-5.30.0.ebuild')
-rw-r--r--dev-lang/perl/perl-5.30.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/perl/perl-5.30.0.ebuild b/dev-lang/perl/perl-5.30.0.ebuild
index 47ecb930d471..97c325fc8693 100644
--- a/dev-lang/perl/perl-5.30.0.ebuild
+++ b/dev-lang/perl/perl-5.30.0.ebuild
@@ -6,7 +6,7 @@ EAPI=6
inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessing
PATCH_VER=1
-CROSS_VER=1.2.2
+CROSS_VER=1.3
PATCH_BASE="perl-5.30.0-patches-${PATCH_VER}"
PATCH_DEV=dilfridge
@@ -464,9 +464,11 @@ src_configure() {
# fix unaligned access misdetection
# https://rt.perl.org/Public/Bug/Display.html?id=133495
- # bug #676062
- use hppa || use sparc || [[ ${CHOST} == sparc*-solaris* ]] && \
- myconf "-Dd_u32align='define'"
+ # https://rt.perl.org/Public/Bug/Display.html?id=133803
+ # bug #676062, bug #688432
+ use hppa || use sparc || [[ ${CHOST} == sparc*-solaris* ]] || \
+ [[ ${CHOST} == armv5tel* ]] \
+ && myconf "-Dd_u32align='define'"
# Prefix: the host system needs not to follow Gentoo multilib stuff, and in
# Prefix itself we don't do multilib either, so make sure perl can find