summaryrefslogtreecommitdiff
path: root/dev-lang/perl/perl-5.28.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-lang/perl/perl-5.28.9999.ebuild
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/perl/perl-5.28.9999.ebuild')
-rw-r--r--dev-lang/perl/perl-5.28.9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/perl/perl-5.28.9999.ebuild b/dev-lang/perl/perl-5.28.9999.ebuild
index 297e1ce4cd6d..3fee6ac8677a 100644
--- a/dev-lang/perl/perl-5.28.9999.ebuild
+++ b/dev-lang/perl/perl-5.28.9999.ebuild
@@ -7,7 +7,7 @@ inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessin
PATCH_VER=1
CROSS_VER=1.1.9
-PATCH_BASE="perl-5.28.0-RC2-patches-${PATCH_VER}"
+PATCH_BASE="perl-5.28.0-patches-${PATCH_VER}"
DIST_AUTHOR=XSAWYERX
@@ -370,6 +370,9 @@ src_configure() {
# Fixes bug #143895 on gcc-4.1.1
filter-flags "-fsched2-use-superblocks"
+ # Generic LTO broken since 5.28, triggers EUMM failures
+ filter-flags "-flto"
+
use sparc && myconf -Ud_longdbl
export BUILD_BZIP2=0
@@ -549,6 +552,8 @@ src_configure() {
src_test() {
export NO_GENTOO_NETWORK_TESTS=1;
+ export GENTOO_ASSUME_SANDBOXED="${GENTOO_ASSUME_SANDBOXED:-1}"
+ export GENTOO_NO_PORTING_TESTS="${GENTOO_NO_PORTING_TESTS:-1}"
if [[ ${EUID} == 0 ]] ; then
ewarn "Test fails with a sandbox error (#328793) if run as root. Skipping tests..."
return 0