summaryrefslogtreecommitdiff
path: root/dev-lang/nprolog/nprolog-1.92.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-04 09:02:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-04 09:02:03 +0000
commitacf34cb86be38d3601273c231058d3fda627e618 (patch)
tree73d77f0d1f7bec82f0b43678f9aa87f0b359cd91 /dev-lang/nprolog/nprolog-1.92.ebuild
parent0b0f15411ade2ffeba5d057f14bd8bc7dfdcf440 (diff)
gentoo auto-resync : 04:12:2022 - 09:02:03
Diffstat (limited to 'dev-lang/nprolog/nprolog-1.92.ebuild')
-rw-r--r--dev-lang/nprolog/nprolog-1.92.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/nprolog/nprolog-1.92.ebuild b/dev-lang/nprolog/nprolog-1.92.ebuild
new file mode 100644
index 000000000000..98dfe542444d
--- /dev/null
+++ b/dev-lang/nprolog/nprolog-1.92.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler to be compatible with Arity/Prolog32"
+HOMEPAGE="https://github.com/sasagawa888/nprolog/"
+SRC_URI="https://github.com/sasagawa888/nprolog/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README{,-ja}.md document )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LIBS="-lm -ldl ${LDFLAGS}"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe npl
+
+ insinto /usr/share/${PN}
+ doins -r example library
+
+ einstalldocs
+}