summaryrefslogtreecommitdiff
path: root/dev-lang/mujs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-lang/mujs/files
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-lang/mujs/files')
-rw-r--r--dev-lang/mujs/files/mujs-1.0.1-gentoo.patch37
-rw-r--r--dev-lang/mujs/files/mujs-1.0.5-flags.patch30
2 files changed, 30 insertions, 37 deletions
diff --git a/dev-lang/mujs/files/mujs-1.0.1-gentoo.patch b/dev-lang/mujs/files/mujs-1.0.1-gentoo.patch
deleted file mode 100644
index c6c7977ac75d..000000000000
--- a/dev-lang/mujs/files/mujs-1.0.1-gentoo.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2,7 +2,7 @@
-
- build ?= release
-
--prefix ?= /usr/local
-+prefix ?= /usr
- bindir ?= $(prefix)/bin
- incdir ?= $(prefix)/include
- libdir ?= $(prefix)/lib
-@@ -11,7 +11,7 @@
-
- # Compiler flags for various configurations:
-
--CFLAGS := -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
-+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
-
- ifeq "$(CC)" "clang"
- CFLAGS += -Wunreachable-code
-@@ -22,16 +22,6 @@
- LDFLAGS += -Wl,--gc-sections
- endif
-
--ifeq "$(build)" "debug"
--CFLAGS += -g
--else ifeq "$(build)" "sanitize"
--CFLAGS += -pipe -g -fsanitize=address -fno-omit-frame-pointer
--LDFLAGS += -fsanitize=address
--else
--CFLAGS += -Os
--LDFLAGS += -Wl,-s
--endif
--
- # You shouldn't need to edit anything below here.
-
- OUT := build/$(build)
diff --git a/dev-lang/mujs/files/mujs-1.0.5-flags.patch b/dev-lang/mujs/files/mujs-1.0.5-flags.patch
new file mode 100644
index 000000000000..50de4fcff21e
--- /dev/null
+++ b/dev-lang/mujs/files/mujs-1.0.5-flags.patch
@@ -0,0 +1,30 @@
+--- a/Makefile 2018-09-11 12:47:31.000000000 +0200
++++ b/Makefile 2018-10-28 20:09:17.000000000 +0100
+@@ -15,7 +15,7 @@
+
+ # Compiler flags for various configurations:
+
+-CFLAGS := -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
++CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
+
+ ifeq "$(CC)" "clang"
+ CFLAGS += -Wunreachable-code
+@@ -30,9 +30,6 @@
+ else ifeq "$(build)" "sanitize"
+ CFLAGS += -pipe -g -fsanitize=address -fno-omit-frame-pointer
+ LDFLAGS += -fsanitize=address
+-else
+- CFLAGS += -Os
+- LDFLAGS += -Wl,-s
+ endif
+
+ ifeq "$(HAVE_READLINE)" "yes"
+@@ -78,7 +75,7 @@
+
+ $(OUT)/libmujs.so: one.c $(HDRS)
+ @ mkdir -p $(dir $@)
+- $(CC) $(CFLAGS) -fPIC -shared -o $@ $< -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -fPIC -shared -o $@ $< -lm
+
+ $(OUT)/mujs: $(OUT)/libmujs.o $(OUT)/main.o
+ @ mkdir -p $(dir $@)