summaryrefslogtreecommitdiff
path: root/dev-lang/mono/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-lang/mono/files
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-lang/mono/files')
-rw-r--r--dev-lang/mono/files/mono-4.4.1.0-x86_32.patch20
-rw-r--r--dev-lang/mono/files/mono-4.8.0.371-makedev.patch34
-rw-r--r--dev-lang/mono/files/mono-4.8.0.371-x86_32.patch27
3 files changed, 0 insertions, 81 deletions
diff --git a/dev-lang/mono/files/mono-4.4.1.0-x86_32.patch b/dev-lang/mono/files/mono-4.4.1.0-x86_32.patch
deleted file mode 100644
index 751c057e6ce4..000000000000
--- a/dev-lang/mono/files/mono-4.4.1.0-x86_32.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Native toolchain can default to different ABI (amd64 in bug case).
-Set target to i386.
-https://bugs.gentoo.org/600664
-diff -Naur a/mono/mini/aot-compiler.c b/mono/mini/aot-compiler.c
---- a/mono/mini/aot-compiler.c 2016-06-22 04:31:58.000000000 -0500
-+++ b/mono/mini/aot-compiler.c 2017-12-08 14:25:35.338251941 -0600
-@@ -9438,7 +9438,12 @@
- const char *tool_prefix = acfg->aot_opts.tool_prefix ? acfg->aot_opts.tool_prefix : "";
- char *ld_flags = acfg->aot_opts.ld_flags ? acfg->aot_opts.ld_flags : g_strdup("");
-
--#if defined(TARGET_AMD64) && !defined(TARGET_MACH)
-+#if defined(TARGET_X86)
-+#define LD_OPTIONS "-m elf_i386"
-+#if !defined(TARGET_MACH)
-+#define AS_OPTIONS "--32"
-+#endif
-+#elif defined(TARGET_AMD64) && !defined(TARGET_MACH)
- #define AS_OPTIONS "--64"
- #elif defined(TARGET_POWERPC64)
- #define AS_OPTIONS "-a64 -mppc64"
diff --git a/dev-lang/mono/files/mono-4.8.0.371-makedev.patch b/dev-lang/mono/files/mono-4.8.0.371-makedev.patch
deleted file mode 100644
index 7a4a44b3e72d..000000000000
--- a/dev-lang/mono/files/mono-4.8.0.371-makedev.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://bugs.gentoo.org/575232
-diff --git a/configure.ac b/configure.ac
-index fa5977b..2832c69 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -416,6 +416,10 @@ AC_HEADER_STDC
- AC_LIBTOOL_WIN32_DLL
- # This causes monodis to not link correctly
- #AC_DISABLE_FAST_INSTALL
-+
-+#lookup makedev() header
-+AC_HEADER_MAJOR
-+
- AM_PROG_LIBTOOL
- # Use dolt (http://dolt.freedesktop.org/) instead of libtool for building.
- DOLT
-diff --git a/mono/io-layer/processes.c b/mono/io-layer/processes.c
-index 53c271a..7ff8d03 100644
---- a/mono/io-layer/processes.c
-+++ b/mono/io-layer/processes.c
-@@ -45,6 +45,13 @@
- #include <utime.h>
- #endif
-
-+/* makedev() macro */
-+#ifdef MAJOR_IN_MKDEV
-+#include <sys/mkdev.h>
-+#elif defined MAJOR_IN_SYSMACROS
-+#include <sys/sysmacros.h>
-+#endif
-+
- /* sys/resource.h (for rusage) is required when using osx 10.3 (but not 10.4) */
- #ifdef __APPLE__
- #include <TargetConditionals.h>
diff --git a/dev-lang/mono/files/mono-4.8.0.371-x86_32.patch b/dev-lang/mono/files/mono-4.8.0.371-x86_32.patch
deleted file mode 100644
index 063ea634fa4c..000000000000
--- a/dev-lang/mono/files/mono-4.8.0.371-x86_32.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Native toolchain can default to different ABI (amd64 in bug case).
-Set target to i386.
-https://bugs.gentoo.org/600664
-diff --git a/mono/mini/aot-compiler.c b/mono/mini/aot-compiler.c
-index a1c359f..beaaf76 100644
---- a/mono/mini/aot-compiler.c
-+++ b/mono/mini/aot-compiler.c
-@@ -9842,7 +9842,9 @@ compile_asm (MonoAotCompile *acfg)
- const char *tool_prefix = acfg->aot_opts.tool_prefix ? acfg->aot_opts.tool_prefix : "";
- char *ld_flags = acfg->aot_opts.ld_flags ? acfg->aot_opts.ld_flags : g_strdup("");
-
--#if defined(TARGET_AMD64) && !defined(TARGET_MACH)
-+#if defined(TARGET_X86) && !defined(TARGET_MACH)
-+#define AS_OPTIONS "--32"
-+#elif defined(TARGET_AMD64) && !defined(TARGET_MACH)
- #define AS_OPTIONS "--64"
- #elif defined(TARGET_POWERPC64)
- #define AS_OPTIONS "-a64 -mppc64"
-@@ -9886,6 +9888,8 @@ compile_asm (MonoAotCompile *acfg)
- #define LD_OPTIONS "--shared"
- #elif defined(TARGET_POWERPC64)
- #define LD_OPTIONS "-m elf64ppc"
-+#elif defined(TARGET_X86)
-+#define LD_OPTIONS "-m elf_i386"
- #endif
-
- #ifndef LD_OPTIONS