summaryrefslogtreecommitdiff
path: root/dev-lang/micropython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-20 20:08:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-20 20:08:51 +0000
commitd3419aa304ff2564036398be5e8ed4bdeaeaa007 (patch)
tree40ed2d4f8dd5f80c5647645dc91bb22deb7c4d8a /dev-lang/micropython
parent6aa0d33a65c735f3148967b62316c2e71f43589a (diff)
gentoo auto-resync : 20:01:2024 - 20:08:51
Diffstat (limited to 'dev-lang/micropython')
-rw-r--r--dev-lang/micropython/Manifest3
-rw-r--r--dev-lang/micropython/files/micropython-1.17-gcc13-build-fix.patch62
-rw-r--r--dev-lang/micropython/micropython-1.17.ebuild1
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-lang/micropython/Manifest b/dev-lang/micropython/Manifest
index 7539bfa5ecbe..3b1908e6ea89 100644
--- a/dev-lang/micropython/Manifest
+++ b/dev-lang/micropython/Manifest
@@ -1,5 +1,6 @@
AUX micropython-1.17-exclude-float-parse-tests.patch 525 BLAKE2B f9a3b7c8f625edcac31be6df9dd7936e9f9099995875e55882206241a24c252148b64ec726643d1700ad59d615cabdaa69377d2d303e4572dc2f600255c76930 SHA512 e5c67b461fd132b71ca87325cb4a4fe5608b18d6b1e058746d87d39832c92bcc9673366755292d6cb51fd2770a2ddea0688bcdd7f2052a2c2ee2f180e9b63c69
+AUX micropython-1.17-gcc13-build-fix.patch 1826 BLAKE2B 3212ce3d7ef51f9163a143b1a3727770a6c9b049e7a4b386117366af7cc451ac1740cf217772f6b9a6fe531ec9c610bd61b143e428fad19cccf96c295e58b97d SHA512 540a38b845f7e457fa19e8645f62bc1bd7972e29d5414dba76d8f72d9c4279e49f906b04e7e96c2f61a60da9cac4a9d5c2ca688a436376e8c203fe0959249b25
AUX micropython-1.17-prevent-stripping.patch 461 BLAKE2B 9daee505d5c446a3a6756336cfc5fb016053f36f5f567cf35aa6ab9a1b794a28fd92b81a27ffc2ce077a75c422c9b2a957c417b561edcf85ffa5653e1eddec41 SHA512 0cd5a8c499552b0728242af531406e0d26d91f560d7d4b38ea6fd0bc0b43639e77af9e56b6b89cba5d5661131357fa1a714c3fe734e3ab59f60fc63258d00c4c
DIST micropython-1.17.tar.xz 56606868 BLAKE2B a6338d173de646764c1573ebabdb9818746a479fd2dd618f9be9955881e3829c4d89da4602934e71655734ec1c6f2150a6ac2c54a5fed9bee998905a00d5c6ea SHA512 8074214040e35ae1ca99721ec442f4cef70fa03380b7662016c55cb3acff9178fc54140c0d818c9581389b4daaade142ecf75b65a2919c666a50255423a39a54
-EBUILD micropython-1.17.ebuild 1387 BLAKE2B 503d9007d4271d3362acbd4936371f4cd0277ee6ea8e5264f4aa9b12f433d77698c656594709066507af8df0f6d3b3e905c8af13cb2042271e7cb3bec610c92b SHA512 834c9041c849144ca000d8a5cefb589f54ac7efeef36fce99d5ea9748813027297d12257b44d47b27ea271048e312c1af14bb1d9c64d3dc5955dc5a97d332e25
+EBUILD micropython-1.17.ebuild 1429 BLAKE2B 9779c5a596e49068b07a91f635928a842d71927c389ca55403040c84dc6d02510948975112688d4924945bf7c119fc20fba1caf72f4b13ba46b0f7aade5f6ef9 SHA512 f2e43607d1abee316ddb8ea80ffcee828eb9785285574696266c55c3cfa0f5872f731232ee14158dc55970bfe9d9d72a50b4f905558465effc7fe440e558bf6e
MISC metadata.xml 1247 BLAKE2B f08da5a443696e12372f245081e7938c59069e9f57195b3c1c17758c2809dc4a4cfab8133dda55c74d1e014848a78ea01fdf4c8c5a863da15856d183537d7686 SHA512 74c8946a2c321e9c03b11985fa5b23f5055be6a4b268b933cb5337751bdf31516fde8c83cdf4d8c39b161072a05cc3e781f64a5ad5a7323c735b85d7af5051ad
diff --git a/dev-lang/micropython/files/micropython-1.17-gcc13-build-fix.patch b/dev-lang/micropython/files/micropython-1.17-gcc13-build-fix.patch
new file mode 100644
index 000000000000..306db8d9caa8
--- /dev/null
+++ b/dev-lang/micropython/files/micropython-1.17-gcc13-build-fix.patch
@@ -0,0 +1,62 @@
+https://github.com/micropython/micropython/pull/11402
+https://github.com/micropython/micropython/commit/32572439984e5640c6af46fbe7c27400c30112ce
+
+From f1c6cb7725960487195daa5c5c196fd8d3563811 Mon Sep 17 00:00:00 2001
+From: Damien George <damien@micropython.org>
+Date: Wed, 3 May 2023 15:23:24 +1000
+Subject: [PATCH] py/stackctrl: Add gcc pragmas to ignore dangling-pointer
+ warning.
+
+This warning became apparent in gcc 13.
+
+Signed-off-by: Damien George <damien@micropython.org>
+---
+ py/stackctrl.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/py/stackctrl.c b/py/stackctrl.c
+index c2f3adb5eedc..c2566ebad92b 100644
+--- a/py/stackctrl.c
++++ b/py/stackctrl.c
+@@ -28,8 +28,15 @@
+ #include "py/stackctrl.h"
+
+ void mp_stack_ctrl_init(void) {
++ #if __GNUC__ >= 13
++ #pragma GCC diagnostic push
++ #pragma GCC diagnostic ignored "-Wdangling-pointer"
++ #endif
+ volatile int stack_dummy;
+ MP_STATE_THREAD(stack_top) = (char *)&stack_dummy;
++ #if __GNUC__ >= 13
++ #pragma GCC diagnostic pop
++ #endif
+ }
+
+ void mp_stack_set_top(void *top) {
+
+From 32572439984e5640c6af46fbe7c27400c30112ce Mon Sep 17 00:00:00 2001
+From: Damien George <damien@micropython.org>
+Date: Tue, 7 Mar 2023 14:46:22 +1100
+Subject: [PATCH] mpy-cross/main: Fix return type of mp_import_stat.
+
+Fixes issue #10951.
+
+Signed-off-by: Damien George <damien@micropython.org>
+---
+ mpy-cross/main.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mpy-cross/main.c b/mpy-cross/main.c
+index 13bb17b13dba..8a4dd5bcbed5 100644
+--- a/mpy-cross/main.c
++++ b/mpy-cross/main.c
+@@ -344,7 +344,7 @@ int main(int argc, char **argv) {
+ return main_(argc, argv);
+ }
+
+-uint mp_import_stat(const char *path) {
++mp_import_stat_t mp_import_stat(const char *path) {
+ (void)path;
+ return MP_IMPORT_STAT_NO_EXIST;
+ }
diff --git a/dev-lang/micropython/micropython-1.17.ebuild b/dev-lang/micropython/micropython-1.17.ebuild
index 352bc9cfea11..16620cf90890 100644
--- a/dev-lang/micropython/micropython-1.17.ebuild
+++ b/dev-lang/micropython/micropython-1.17.ebuild
@@ -22,6 +22,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}/${P}-prevent-stripping.patch"
"${FILESDIR}/${P}-exclude-float-parse-tests.patch"
+ "${FILESDIR}/${P}-gcc13-build-fix.patch"
)
src_prepare() {