summaryrefslogtreecommitdiff
path: root/dev-lang/luau
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-10 22:28:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-10 22:28:10 +0100
commitf2a91413828611d85d0496e98e1656e9b0e4528b (patch)
treeb3998888d687ece7d9aabfa86c9b449e5438a513 /dev-lang/luau
parentb98a1d0a0651765f29a8aeab25f904e730dfbf88 (diff)
gentoo auto-resync : 10:07:2023 - 22:28:10
Diffstat (limited to 'dev-lang/luau')
-rw-r--r--dev-lang/luau/Manifest3
-rw-r--r--dev-lang/luau/luau-0.583.ebuild36
-rw-r--r--dev-lang/luau/metadata.xml24
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-lang/luau/Manifest b/dev-lang/luau/Manifest
new file mode 100644
index 000000000000..30a74e5b47b8
--- /dev/null
+++ b/dev-lang/luau/Manifest
@@ -0,0 +1,3 @@
+DIST luau-0.583.tar.gz 5575214 BLAKE2B 17088d4d5026854a5aac29d80a20ab8901753a3d8b89c21491df44202d07433f801d10a8e9443bc21f3318cda059000e43ed2cc2cb5926d3464f47ac7352a3c4 SHA512 45964e485354839c42b44f1482b372d47bce95302122fbba2288a0880bc964e30e934bdd6a62d0b6b2e6d725bdbe3332f67dc136fa64b28be9b3a0b2bc55d16b
+EBUILD luau-0.583.ebuild 765 BLAKE2B 23f9d13f1fac061da43c18a71ce4dd742e8ff880d38da327fbb50859d0d8769bf86330785b09289d5323d6dd28166e1beee706e9bf669c5a9812a462be5056bb SHA512 5d6f371e31c1cf2d3a0ec657c133c6bd0543b2b02d09c7d5b75ac7724ff318c30da842fc5337277b57ad44b82e656d0e9a444a4907cfd742a967aff9bc67496f
+MISC metadata.xml 1071 BLAKE2B 21583b8ae784e9d98bf3f05cc8cca796e6e77b348ff43e52954a4aa67b805beaaf20c2f116753ed41764b51d85d4c673cd92e757053653bd8fc7bb8ab5d4ba79 SHA512 1a98dcfd442fc107c206c21c3ad3e464eec4ed3a77250b6dcaf982078553f612b1c6308a19a586835e6e17d3b6e208ecb6eca64b79fa2ad26f871b42e1711fe0
diff --git a/dev-lang/luau/luau-0.583.ebuild b/dev-lang/luau/luau-0.583.ebuild
new file mode 100644
index 000000000000..c7bee4916d90
--- /dev/null
+++ b/dev-lang/luau/luau-0.583.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Gradually typed embeddable scripting language derived from Lua"
+HOMEPAGE="https://luau-lang.org/
+ https://github.com/Roblox/luau/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Roblox/${PN}.git"
+else
+ SRC_URI="https://github.com/Roblox/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( CONTRIBUTING.md README.md SECURITY.md )
+
+src_test() {
+ "${BUILD_DIR}"/Luau.UnitTest || die
+ "${BUILD_DIR}"/Luau.Conformance || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe "${BUILD_DIR}"/luau{,-analyze,-ast,-compile,-reduce}
+
+ einstalldocs
+}
diff --git a/dev-lang/luau/metadata.xml b/dev-lang/luau/metadata.xml
new file mode 100644
index 000000000000..bc6dc6ae3533
--- /dev/null
+++ b/dev-lang/luau/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Luau is a fast, small, safe, gradually typed embeddable scripting language
+ derived from Lua. It is designed to be backwards compatible with Lua 5.1,
+ as well as incorporating some features from future Lua releases, but also
+ expands the feature set (most notably with type annotations). Luau is
+ largely implemented from scratch, with the language runtime being a very
+ heavily modified version of Lua 5.1 runtime, with completely rewritten
+ interpreter and other performance innovations. The runtime mostly preserves
+ Lua 5.1 API, so existing bindings should be more or less compatible with a
+ few caveats.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/Roblox/luau/issues/</bugs-to>
+ <remote-id type="github">Roblox/luau</remote-id>
+ </upstream>
+</pkgmetadata>