summaryrefslogtreecommitdiff
path: root/dev-lang/jwasm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-lang/jwasm
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-lang/jwasm')
-rw-r--r--dev-lang/jwasm/Manifest2
-rw-r--r--dev-lang/jwasm/jwasm-2.13.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/jwasm/Manifest b/dev-lang/jwasm/Manifest
index 419285044996..5b121c5ce689 100644
--- a/dev-lang/jwasm/Manifest
+++ b/dev-lang/jwasm/Manifest
@@ -1,4 +1,6 @@
AUX jwasm-2.11-types-test.patch 1761 BLAKE2B b719bb79504e708925bfa407e72df7a37044b834bc3118fa9baf1a0cb478a0ab852872147148462188324954ef958af30cbcbca28fc992660276a15100ecb1b6 SHA512 0a4f3e613c8e724939ce9e23f8f4ce10ca89bf6c1579929719b3ccad62ac66cceecc3f8799c20c2875b7d4dcc7390bf0e4ca64aa08aab0b39bd7a4ab381b150b
DIST JWasm211as.zip 1004993 BLAKE2B 725489690048b049c7fec5f2c54b89a746ee1c825d44e6f4f912f568b737c8ad996e55dba112132e685665b4d47aadd0324b2e9480d421c497bc21abbb85d015 SHA512 3e48e09955ccf8e641b36f54c93c3f36b275a0e662013a17dfd1f52a3e2872eff54be869596d0e72bdb2cc7e59c8fd1dee13477bf89a59bba4b212959cff9006
+DIST jwasm-2.13.tar.gz 578365 BLAKE2B 8c6fbe3e6cb56c0fe8135c30c629534d2b6e2a2ed534249834e0e2674bf6635cb15ab94d4fa05c5378cb0db8569ddc3ba49d2d7c9615b7ddb769cba1a2d5b715 SHA512 03f80f4a74b39c6093f5cd5334364f7458836a52ad01279c95683e7053cb4211c40235e16f6f2ee40bc7316dcd8a4fbcb57bf3606d31249d96d01933a8aa0563
EBUILD jwasm-2.11a-r1.ebuild 811 BLAKE2B e560b9f9d515567f25c1b2a94315bf244f8dcc31dcc03ebc5a3c99d1187c53e0f0015ce8722132d09b08b77a38cfefadff4c58f084d7638f5d9a8e12d9339dd4 SHA512 0e3fa6059a4c0800f0a1e850193ba5451782abe7ad4f1ccbf99f9401f6bc36a28252dbeb5fc9934419a5095a938fc65990dc67b9c92e68205d06b0ec29df8559
+EBUILD jwasm-2.13.ebuild 730 BLAKE2B c54d0438b6fcb0d339ae7b8d10a9948b2099c8db3b5f3e68a521d75979d3b6b51eab780530eb67d6e84af6ebe6e9b9c76464cebf1fb7a0d7e6a2d8dfd8c91464 SHA512 7269d7e817d3348b794878bc57fc729d14142c97adc0022adf1fd82eb3447a037127e0d44ae90f1baaa44a4966053f1b41e3043e8e009aa61594a4876df59807
MISC metadata.xml 326 BLAKE2B 6824de006351db2d3fcd9da82e45fe8c81c083209af168ef5a4cb838e44cdf951377ddebd539b198b9fdb082b4ae384dc2d6cf0357ed86e234c7226f2234af27 SHA512 ff2d01893c3ac2522da224e1526c83f9b0c081e21d735064da6b71163e8f3b8e6c3ac2e27b083b03b30c54af433c4cad29efea7984367c56d077c804675872ba
diff --git a/dev-lang/jwasm/jwasm-2.13.ebuild b/dev-lang/jwasm/jwasm-2.13.ebuild
new file mode 100644
index 000000000000..ecb666549892
--- /dev/null
+++ b/dev-lang/jwasm/jwasm-2.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MASM-compatible TASM-similar assembler (fork of Wasm)"
+HOMEPAGE="https://github.com/JWasm/JWasm"
+SRC_URI="https://github.com/JWasm/JWasm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Watcom-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/JWasm-${PV}"
+
+PATCHES=("${FILESDIR}"/${PN}-2.11-types-test.patch)
+
+src_prepare() {
+ default
+
+ # don't strip binary
+ sed -i GccUnix.mak -e 's/ -s / /g' || die
+}
+
+src_compile() {
+ emake -f GccUnix.mak CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin GccUnixR/jwasm
+ dodoc *.txt Doc/*.txt
+}