summaryrefslogtreecommitdiff
path: root/dev-lang/julia/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/julia/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/julia/files')
-rw-r--r--dev-lang/julia/files/julia-0.6.3-fix_build_system.patch96
-rw-r--r--dev-lang/julia/files/julia-9999-fix_build_system.patch75
2 files changed, 0 insertions, 171 deletions
diff --git a/dev-lang/julia/files/julia-0.6.3-fix_build_system.patch b/dev-lang/julia/files/julia-0.6.3-fix_build_system.patch
deleted file mode 100644
index 41e64672adf8..000000000000
--- a/dev-lang/julia/files/julia-0.6.3-fix_build_system.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-diff --git a/Make.inc b/Make.inc
-index 7f3a37c..3560d93 100644
---- a/Make.inc
-+++ b/Make.inc
-@@ -180,7 +180,7 @@ USE_GPL_LIBS ?= 1
- # Directories where said libraries get installed to
- prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
- bindir := $(prefix)/bin
--libdir := $(prefix)/lib
-+libdir := $(prefix)/GENTOOLIBDIR
- libexecdir := $(prefix)/libexec
- datarootdir := $(prefix)/share
- docdir := $(datarootdir)/doc/julia
-@@ -400,7 +400,7 @@ ifneq ($(OS), WINNT)
- JCXXFLAGS += -pedantic
- endif
- DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -ggdb2 -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECLANG),1)
-@@ -411,7 +411,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS := -fasynchronous-unwind-tables
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g
-+SHIPFLAGS := GENTOOCFLAGS
- ifeq ($(OS), Darwin)
- ifeq ($(USE_LIBCPP), 1)
- MACOSX_VERSION_MIN := 10.8
-@@ -440,7 +440,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS :=
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECCACHE), 1)
-diff --git a/deps/tools/jldownload b/deps/tools/jldownload
-index ab4fd69..e2c2408 100755
---- a/deps/tools/jldownload
-+++ b/deps/tools/jldownload
-@@ -5,9 +5,9 @@
-
- CACHE_HOST=https://cache.julialang.org
-
--WGET=$(which wget 2>/dev/null)
--CURL=$(which curl 2>/dev/null)
--FETCH=$(which fetch 2>/dev/null)
-+WGET=/bin/true
-+CURL=/bin/true
-+FETCH=/bin/true
-
- TIMEOUT=15 # seconds
- WGET_OPTS="--no-check-certificate --tries=1 --timeout=$TIMEOUT"
-diff --git a/doc/Makefile b/doc/Makefile
-index 743804d..e06dde0 100644
---- a/doc/Makefile
-+++ b/doc/Makefile
-@@ -25,7 +25,7 @@ deps: UnicodeData.txt
- $(JLCHECKSUM) UnicodeData.txt
-
- clean:
-- -rm -rf _build/* deps/* docbuild.log UnicodeData.txt
-+ @echo "Do not clean doc/_build/html. Just use it..."
-
- cleanall: clean
-
-diff --git a/src/Makefile b/src/Makefile
-index 9fde74d..e01ab2e 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -85,20 +85,8 @@ PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLI
-
- # In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
- # In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
--ifneq ($(USE_LLVM_SHLIB),1)
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --libs $(LLVM_LIBS)) $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --system-libs 2> /dev/null)
--else
--ifeq ($(LLVM_USE_CMAKE),1)
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM
--else
--ifeq ($(OS),WINNT)
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(LLVM_VER_SHORT)
--else
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(shell $(LLVM_CONFIG_HOST) --version)
--endif # OS == WINNT
--endif # LLVM_USE_CMAKE == 1
-+LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
- FLAGS += -DLLVM_SHLIB
--endif # USE_LLVM_SHLIB == 1
-
- COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)
- DEBUG_LIBS := $(WHOLE_ARCHIVE) $(BUILDDIR)/flisp/libflisp-debug.a $(WHOLE_ARCHIVE) $(BUILDDIR)/support/libsupport-debug.a $(COMMON_LIBS)
diff --git a/dev-lang/julia/files/julia-9999-fix_build_system.patch b/dev-lang/julia/files/julia-9999-fix_build_system.patch
deleted file mode 100644
index 336d6e3e590c..000000000000
--- a/dev-lang/julia/files/julia-9999-fix_build_system.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff --git a/Make.inc b/Make.inc
-index 8cb2c1014..d3be9de8e 100644
---- a/Make.inc
-+++ b/Make.inc
-@@ -178,7 +178,7 @@ USE_GPL_LIBS ?= 1
- # Directories where said libraries get installed to
- prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
- bindir := $(prefix)/bin
--libdir := $(prefix)/lib
-+libdir := $(prefix)/GENTOOLIBDIR
- libexecdir := $(prefix)/libexec
- datarootdir := $(prefix)/share
- docdir := $(datarootdir)/doc/julia
-@@ -410,7 +410,7 @@ ifneq ($(OS), WINNT)
- JCXXFLAGS += -pedantic
- endif
- DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -ggdb2 -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECLANG),1)
-@@ -421,7 +421,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS := -fasynchronous-unwind-tables
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g
-+SHIPFLAGS := GENTOOCFLAGS
- ifeq ($(OS), Darwin)
- ifeq ($(USE_LIBCPP), 1)
- MACOSX_VERSION_MIN := 10.8
-@@ -450,7 +450,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS :=
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECCACHE), 1)
-diff --git a/doc/Makefile b/doc/Makefile
-index 89b79880d..c3125fde1 100644
---- a/doc/Makefile
-+++ b/doc/Makefile
-@@ -29,7 +29,7 @@ deps: UnicodeData.txt
- $(JLCHECKSUM) UnicodeData.txt
-
- clean:
-- -rm -rf _build/* deps/* docbuild.log UnicodeData.txt
-+ @echo "Do not clean doc/_build/html. Just use it..."
-
- cleanall: clean
-
-diff --git a/src/Makefile b/src/Makefile
-index 257152d24..240a4a350 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -85,16 +85,7 @@ UV_HEADERS += uv/*.h
- endif
- PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLIC_HEADERS)) $(UV_HEADERS))
-
--ifeq ($(JULIACODEGEN),LLVM)
--# In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
--# In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
--ifneq ($(USE_LLVM_SHLIB),1)
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --libs $(LLVM_LIBS)) $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --system-libs 2> /dev/null)
--else
--LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM
--FLAGS += -DLLVM_SHLIB
--endif # USE_LLVM_SHLIB == 1
--endif
-+LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
-
- COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)
- DEBUG_LIBS := $(WHOLE_ARCHIVE) $(BUILDDIR)/flisp/libflisp-debug.a $(WHOLE_ARCHIVE) $(BUILDDIR)/support/libsupport-debug.a $(COMMON_LIBS)