summaryrefslogtreecommitdiff
path: root/dev-lang/jimtcl/jimtcl-0.81.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-lang/jimtcl/jimtcl-0.81.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-lang/jimtcl/jimtcl-0.81.ebuild')
-rw-r--r--dev-lang/jimtcl/jimtcl-0.81.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/jimtcl/jimtcl-0.81.ebuild b/dev-lang/jimtcl/jimtcl-0.81.ebuild
new file mode 100644
index 000000000000..3554df35054f
--- /dev/null
+++ b/dev-lang/jimtcl/jimtcl-0.81.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+SRC_URI="https://github.com/msteveb/jimtcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~x86"
+
+DESCRIPTION="Small footprint implementation of Tcl programming language"
+HOMEPAGE="http://jim.tcl.tk/"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="
+ dev-lang/tcl:0
+"
+
+src_configure() {
+ CCACHE=none econf --disable-docs --shared
+ if use static-libs ; then
+ # The build does not support doing both simultaneously.
+ mkdir static-libs || die
+ cd static-libs || die
+ CCACHE=none ECONF_SOURCE="${S}" econf --disable-docs
+ fi
+}
+
+src_compile() {
+ # Must build static-libs first.
+ use static-libs && emake -C static-libs libjim.a
+ emake all
+}
+
+src_install() {
+ default
+ ln -sf libjim.so.${PV} "${ED}"/usr/$(get_libdir)/libjim.so || die
+ use static-libs && dolib.a static-libs/libjim.a
+ use doc && dodoc Tcl_shipped.html
+}