summaryrefslogtreecommitdiff
path: root/dev-lang/ispc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /dev-lang/ispc
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/Manifest4
-rw-r--r--dev-lang/ispc/ispc-1.9.2.ebuild52
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild5
3 files changed, 58 insertions, 3 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index f26b56d316fc..fd339649c2f3 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,4 +1,6 @@
DIST ispc-1.9.1.tar.gz 19276043 BLAKE2B a9cc96b138cc5424e3a09fa517c8554f79af3c947c05a75c179b35e509e399785da18f72b0a2e0d81be8ea8f04b3ca0f6a90003a76d5d9ac641f55cfdcd47dfc SHA512 4acd9e99dadba684829235a267e15ca8ff4cf33c4cadaa2983006bcb2c2f45fce49e8b11963f4bce78c256aaf8ece0583cf6cb729c6bc75af32b7fa4238ca743
+DIST ispc-1.9.2.tar.gz 19283765 BLAKE2B 500cca8a69a78ad9a21dc1e39dcb3ed01730e78deed61e4871ce5a9761829c80ac7b1b987d8e8a48c34b67ac96692b2c5026cfb5059a32c71e228c73550584eb SHA512 77a66086cbfd6c4dc855b3137a270cc40f24829255639aee5f562b0831c21938157667b20cfadc660cd67525c47e2e73b46692f7a11bf0c834dc60b69d40d76d
EBUILD ispc-1.9.1.ebuild 1100 BLAKE2B d5137a5d3bd3d135c6048ee0e2e71ba609feaca8af9344117b9dec3343c27a260856b40e661ba20724214f2bbade07abb7b7079a080240be54bffe8af92a3ae8 SHA512 0539b86b64f45a7e52ed4a72006cadd3f9eb32ab40ad9b5394f7598923769d716a67ca11c39c637eed677d619cc67c6297ee667c783eb5dba7c95cecfb43e359
-EBUILD ispc-9999.ebuild 1043 BLAKE2B ca831f69684d3fff6415f0464f826561bd0001be619c2e31a37a265003befaba636748b139b0e905b3bc490320c7aff1892903144e9c0f33417243dc72d0789a SHA512 ccc8ae855a867c2cd214cbe1e2ca233b1e198924413d8c552aecaae825534a9beb9be21e41d988bcd7d20360eae320d47fe1d929c01b7c0e80edf7d2790fbde1
+EBUILD ispc-1.9.2.ebuild 1100 BLAKE2B 4bfdcf2d708ddc9e5c9e84f9a8adbab0111ceda9c5a10d7b11b21ef21cb24e56cca857e9cde0d593b0b1c49f1098a1ab0035d239ccc1b268ce1d5832c5979463 SHA512 5595b9a47e860adbfd6c7c9e3fa94f39f68f3d167cf17f3da964e51e8dfff170cf9ef6dcbee8ea82f1813f9a66d3724721ad2b44269e69703842a80d2aa25129
+EBUILD ispc-9999.ebuild 1100 BLAKE2B 4bfdcf2d708ddc9e5c9e84f9a8adbab0111ceda9c5a10d7b11b21ef21cb24e56cca857e9cde0d593b0b1c49f1098a1ab0035d239ccc1b268ce1d5832c5979463 SHA512 5595b9a47e860adbfd6c7c9e3fa94f39f68f3d167cf17f3da964e51e8dfff170cf9ef6dcbee8ea82f1813f9a66d3724721ad2b44269e69703842a80d2aa25129
MISC metadata.xml 327 BLAKE2B 54a38462b0fe6a1ed78bf0098fa3e85c3c7e745e4777a90d9da67286f8f4bd5b3b1df035de5274c6c2cc3f04c4fd454bacf93e6a09ebf6ddb6fa3b832ec82b77 SHA512 94078b0d77481ac78255fc9fbceec4e204b7fa20da59f103d163eb22f33fb78d0dd2ae039157666f6e80eee81922a6e89acc2ddf89d29275ff19ce5e9391ca83
diff --git a/dev-lang/ispc/ispc-1.9.2.ebuild b/dev-lang/ispc/ispc-1.9.2.ebuild
new file mode 100644
index 000000000000..d1c2c2331127
--- /dev/null
+++ b/dev-lang/ispc/ispc-1.9.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit toolchain-funcs python-any-r1
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="https://ispc.github.com/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ispc/ispc.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=sys-devel/clang-3.0:*
+ >=sys-devel/llvm-3.0:*
+ "
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+src_compile() {
+ #make all slient commands ("@") verbose and remove -Werror (ispc/ispc#1295)
+ sed -e '/^\t@/s/@//' -e 's/-Werror//' -i Makefile || die
+ emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+}
+
+src_install() {
+ dobin ispc
+ dodoc README.rst
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index 9960e29ff26f..d1c2c2331127 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -35,7 +35,8 @@ DEPEND="
"
src_compile() {
- sed -i '/^\t@/s/@//' Makefile || die #make all slient commands ("@") verbose
+ #make all slient commands ("@") verbose and remove -Werror (ispc/ispc#1295)
+ sed -e '/^\t@/s/@//' -e 's/-Werror//' -i Makefile || die
emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
}