summaryrefslogtreecommitdiff
path: root/dev-lang/ispc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/ispc
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/Manifest4
-rw-r--r--dev-lang/ispc/ispc-1.9.2.ebuild52
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild52
-rw-r--r--dev-lang/ispc/metadata.xml11
4 files changed, 0 insertions, 119 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
deleted file mode 100644
index d8bda5fa002d..000000000000
--- a/dev-lang/ispc/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST ispc-1.9.2.tar.gz 19283765 BLAKE2B 500cca8a69a78ad9a21dc1e39dcb3ed01730e78deed61e4871ce5a9761829c80ac7b1b987d8e8a48c34b67ac96692b2c5026cfb5059a32c71e228c73550584eb SHA512 77a66086cbfd6c4dc855b3137a270cc40f24829255639aee5f562b0831c21938157667b20cfadc660cd67525c47e2e73b46692f7a11bf0c834dc60b69d40d76d
-EBUILD ispc-1.9.2.ebuild 1100 BLAKE2B 4bfdcf2d708ddc9e5c9e84f9a8adbab0111ceda9c5a10d7b11b21ef21cb24e56cca857e9cde0d593b0b1c49f1098a1ab0035d239ccc1b268ce1d5832c5979463 SHA512 5595b9a47e860adbfd6c7c9e3fa94f39f68f3d167cf17f3da964e51e8dfff170cf9ef6dcbee8ea82f1813f9a66d3724721ad2b44269e69703842a80d2aa25129
-EBUILD ispc-9999.ebuild 1100 BLAKE2B 4bfdcf2d708ddc9e5c9e84f9a8adbab0111ceda9c5a10d7b11b21ef21cb24e56cca857e9cde0d593b0b1c49f1098a1ab0035d239ccc1b268ce1d5832c5979463 SHA512 5595b9a47e860adbfd6c7c9e3fa94f39f68f3d167cf17f3da964e51e8dfff170cf9ef6dcbee8ea82f1813f9a66d3724721ad2b44269e69703842a80d2aa25129
-MISC metadata.xml 327 BLAKE2B 54a38462b0fe6a1ed78bf0098fa3e85c3c7e745e4777a90d9da67286f8f4bd5b3b1df035de5274c6c2cc3f04c4fd454bacf93e6a09ebf6ddb6fa3b832ec82b77 SHA512 94078b0d77481ac78255fc9fbceec4e204b7fa20da59f103d163eb22f33fb78d0dd2ae039157666f6e80eee81922a6e89acc2ddf89d29275ff19ce5e9391ca83
diff --git a/dev-lang/ispc/ispc-1.9.2.ebuild b/dev-lang/ispc/ispc-1.9.2.ebuild
deleted file mode 100644
index d1c2c2331127..000000000000
--- a/dev-lang/ispc/ispc-1.9.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-any-r1
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.com/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ispc/ispc.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=sys-devel/clang-3.0:*
- >=sys-devel/llvm-3.0:*
- "
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- sys-devel/bison
- sys-devel/flex
- "
-
-src_compile() {
- #make all slient commands ("@") verbose and remove -Werror (ispc/ispc#1295)
- sed -e '/^\t@/s/@//' -e 's/-Werror//' -i Makefile || die
- emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
-}
-
-src_install() {
- dobin ispc
- dodoc README.rst
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples/*
- fi
-}
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
deleted file mode 100644
index d1c2c2331127..000000000000
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-any-r1
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.com/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ispc/ispc.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=sys-devel/clang-3.0:*
- >=sys-devel/llvm-3.0:*
- "
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- sys-devel/bison
- sys-devel/flex
- "
-
-src_compile() {
- #make all slient commands ("@") verbose and remove -Werror (ispc/ispc#1295)
- sed -e '/^\t@/s/@//' -e 's/-Werror//' -i Makefile || die
- emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
-}
-
-src_install() {
- dobin ispc
- dodoc README.rst
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples/*
- fi
-}
diff --git a/dev-lang/ispc/metadata.xml b/dev-lang/ispc/metadata.xml
deleted file mode 100644
index c214c07655f0..000000000000
--- a/dev-lang/ispc/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ispc/ispc</remote-id>
- </upstream>
-</pkgmetadata>