summaryrefslogtreecommitdiff
path: root/dev-lang/ispc/ispc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-lang/ispc/ispc-9999.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-lang/ispc/ispc-9999.ebuild')
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index d1c2c2331127..244bb728565a 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit toolchain-funcs python-any-r1
+inherit cmake toolchain-funcs python-any-r1
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="https://ispc.github.com/"
@@ -34,19 +34,26 @@ DEPEND="
sys-devel/flex
"
-src_compile() {
- #make all slient commands ("@") verbose and remove -Werror (ispc/ispc#1295)
- sed -e '/^\t@/s/@//' -e 's/-Werror//' -i Makefile || die
- emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+PATCHES=(
+ "${FILESDIR}/${P}-cmake-gentoo-release.patch"
+ "${FILESDIR}/${P}-llvm-10.patch"
+ "${FILESDIR}/${P}-werror.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ "-DARM_ENABLED=$(usex arm)"
+ )
+ cmake_src_configure
}
src_install() {
- dobin ispc
- dodoc README.rst
+ dobin ${BUILD_DIR}/bin/ispc
+ dodoc README.md
if use examples; then
insinto "/usr/share/doc/${PF}/examples"
docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples/*
+ doins -r ${BUILD_DIR}/examples/*
fi
}