summaryrefslogtreecommitdiff
path: root/dev-lang/ispc/ispc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-lang/ispc/ispc-9999.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-lang/ispc/ispc-9999.ebuild')
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index 07b62cdb24d2..6ccd5fef40af 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -5,7 +5,9 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake toolchain-funcs python-any-r1
+inherit cmake toolchain-funcs python-any-r1 llvm
+
+LLVM_MAX_SLOT=10
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="https://ispc.github.com/"
@@ -22,10 +24,7 @@ LICENSE="BSD BSD-2 UoI-NCSA"
SLOT="0"
IUSE="examples"
-RDEPEND="
- >=sys-devel/clang-3.0:*
- >=sys-devel/llvm-3.0:*
- "
+RDEPEND="<sys-devel/clang-11:="
DEPEND="
${RDEPEND}
${PYTHON_DEPS}
@@ -41,6 +40,10 @@ PATCHES=(
"${FILESDIR}/${PN}-1.13.0-werror.patch"
)
+llvm_check_deps() {
+ has_version -d "sys-devel/clang:${LLVM_SLOT}"
+}
+
src_prepare() {
if use amd64; then
# On amd64 systems, build system enables x86/i686 build too.