summaryrefslogtreecommitdiff
path: root/dev-lang/ispc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
commita88eb1d9b7042912d196e255eeb20e0c77f6cf47 (patch)
tree291cc788e33b3de8bf1b5e3f1fdddf315f2f5ee7 /dev-lang/ispc/files
parentc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (diff)
gentoo auto-resync : 01:05:2023 - 17:20:35
Diffstat (limited to 'dev-lang/ispc/files')
-rw-r--r--dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch b/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch
new file mode 100644
index 000000000000..19a19e871ee7
--- /dev/null
+++ b/dev-lang/ispc/files/ispc-1.19.0-curses-cmake.patch
@@ -0,0 +1,16 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -598,11 +598,8 @@ else()
+ target_link_libraries(${PROJECT_NAME} pthread tinfo.a curses.a)
+ else()
+ find_package(Curses REQUIRED)
+- if (CURSES_EXTRA_LIBRARY)
+- # this contains the tinfo library, if found
+- target_link_libraries(${PROJECT_NAME} ${CURSES_EXTRA_LIBRARY})
+- endif()
+- target_link_libraries(${PROJECT_NAME} pthread ${CURSES_CURSES_LIBRARY})
++ set(CURSES_NEED_NCURSES ON)
++ target_link_libraries(${PROJECT_NAME} pthread ${CURSES_LIBRARIES})
+ endif()
+ endif()
+