summaryrefslogtreecommitdiff
path: root/dev-lang/go/go-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-11 03:33:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-11 03:33:50 +0100
commit9b97cf60d2411c33c1b2170b730b345ea9995002 (patch)
tree20f1731a35de056eaa5e40343e8aa59e6d1cc564 /dev-lang/go/go-9999.ebuild
parent9cb92979365e38a8c7ac40e7fd7475b99fe1e7ba (diff)
gentoo auto-resync : 11:08:2023 - 03:33:50
Diffstat (limited to 'dev-lang/go/go-9999.ebuild')
-rw-r--r--dev-lang/go/go-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index ee74dcbc30da..68b33c5e0315 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -121,6 +121,10 @@ go_cross_compile() {
[[ $(go_tuple ${CBUILD}) != $(go_tuple) ]]
}
+PATCHES=(
+ "${FILESDIR}"/go-never-download-newer-toolchains.patch
+)
+
src_compile() {
if has_version -b ">=dev-lang/go-${GO_BOOTSTRAP_MIN}"; then
export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go"
@@ -167,15 +171,14 @@ src_test() {
}
src_install() {
- # There is a known issue which requires the source tree to be installed [1].
- # Once this is fixed, we can consider using the doc use flag to control
- # installing the doc and src directories.
- # The use of cp is deliberate in order to retain permissions
- # [1] https://golang.org/issue/2775
dodir /usr/lib/go
+ # The use of cp is deliberate in order to retain permissions
cp -R api bin doc lib pkg misc src test "${ED}"/usr/lib/go
einstalldocs
+ insinto /usr/lib/go
+doins go.env VERSION
+
# testdata directories are not needed on the installed system
rm -fr $(find "${ED}"/usr/lib/go -iname testdata -type d -print)