summaryrefslogtreecommitdiff
path: root/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
commitc92d0cd2b34d17bce6d5bb4e3a4fc00af4193c99 (patch)
tree517559f918260cf91e7bdd4e484aa6fe9085cb9f /dev-lang/gnucobol/gnucobol-3.1.2.ebuild
parenta59ffccce3bf214fae9932cc42400eeeaec25c6c (diff)
gentoo auto-resync : 24:11:2022 - 13:10:39
Diffstat (limited to 'dev-lang/gnucobol/gnucobol-3.1.2.ebuild')
-rw-r--r--dev-lang/gnucobol/gnucobol-3.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-lang/gnucobol/gnucobol-3.1.2.ebuild b/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
new file mode 100644
index 000000000000..8202373ea8e8
--- /dev/null
+++ b/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A free/libre COBOL compiler"
+HOMEPAGE="https://gnucobol.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="GPL-3 LGPL-3 FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="berkdb json nls xml"
+
+RDEPEND="
+ dev-libs/gmp:=
+ sys-libs/ncurses:=
+ json? ( dev-libs/json-c:= )
+ xml? ( dev-libs/libxml2 )
+ berkdb? ( sys-libs/db:4.8= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/libtool"
+
+DOCS=( AUTHORS ChangeLog NEWS README README.md )
+
+src_configure() {
+ econf \
+ $(use_with berkdb db) \
+ $(use_with json) \
+ $(use_with xml xml2) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}