summaryrefslogtreecommitdiff
path: root/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 19:15:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 19:15:12 +0000
commitb3e456d42287ef73c7ff48148d18a9ea8fb8debf (patch)
tree1c9ad46437b76c8af060cd54ff3ceb0f8678b6ce /dev-lang/gnucobol/gnucobol-3.1.2.ebuild
parent7de40ae3e1ba40671bc9aac9ebbf3f42952a036b (diff)
gentoo auto-resync : 26:11:2022 - 19:15:12
Diffstat (limited to 'dev-lang/gnucobol/gnucobol-3.1.2.ebuild')
-rw-r--r--dev-lang/gnucobol/gnucobol-3.1.2.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-lang/gnucobol/gnucobol-3.1.2.ebuild b/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
index 8202373ea8e8..b6419a90cf82 100644
--- a/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
+++ b/dev-lang/gnucobol/gnucobol-3.1.2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="A free/libre COBOL compiler"
HOMEPAGE="https://gnucobol.sourceforge.io/"
SRC_URI="mirror://sourceforge/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
@@ -24,6 +26,13 @@ BDEPEND="sys-devel/libtool"
DOCS=( AUTHORS ChangeLog NEWS README README.md )
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_with berkdb db) \