summaryrefslogtreecommitdiff
path: root/dev-lang/eisl/eisl-3.72.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-05 02:14:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-05 02:14:48 +0100
commit8c11cf748cc296d6338a189106a8cc9e3a1e0948 (patch)
treeaeece5fc6153ff97d650c5333accee0939ba4a92 /dev-lang/eisl/eisl-3.72.ebuild
parent34f71cb8541190212fa250ceb3dafb53f383beea (diff)
gentoo auto-resync : 05:04:2024 - 02:14:48
Diffstat (limited to 'dev-lang/eisl/eisl-3.72.ebuild')
-rw-r--r--dev-lang/eisl/eisl-3.72.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-lang/eisl/eisl-3.72.ebuild b/dev-lang/eisl/eisl-3.72.ebuild
new file mode 100644
index 000000000000..0ef48728bee1
--- /dev/null
+++ b/dev-lang/eisl/eisl-3.72.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
+HOMEPAGE="https://github.com/sasagawa888/eisl/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
+else
+ SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+RESTRICT="test" # Tests run cppcheck (and fail)
+
+DOCS=( README{,-ja}.md documents )
+
+RDEPEND="
+ sys-libs/ncurses:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.60-Makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" clean edlis eisl
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe edlis eisl
+
+ # Compilation of ISLisp files on installation fails.
+ # Do not compile them and mimic "make install".
+ insinto "/usr/share/${PN}"
+ doins -r library
+ doins fast.h ffi.h
+
+ einstalldocs
+}