summaryrefslogtreecommitdiff
path: root/dev-lang/eisl/eisl-3.60.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
commit39ca6159b9ac903dc56818918d9f97bc831f0955 (patch)
treee9b34845be7f96bc244fd239f6dd8090096ce703 /dev-lang/eisl/eisl-3.60.ebuild
parentbc968d15e7f24968eb69567c7f2fca470fdedacd (diff)
gentoo auto-resync : 04:11:2023 - 22:13:37
Diffstat (limited to 'dev-lang/eisl/eisl-3.60.ebuild')
-rw-r--r--dev-lang/eisl/eisl-3.60.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lang/eisl/eisl-3.60.ebuild b/dev-lang/eisl/eisl-3.60.ebuild
new file mode 100644
index 000000000000..866b41aa1866
--- /dev/null
+++ b/dev-lang/eisl/eisl-3.60.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
+HOMEPAGE="https://github.com/sasagawa888/eisl/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
+else
+ SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+RESTRICT="test" # Tests run cppcheck (and fail)
+
+DOCS=( README{,-ja}.md documents )
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.60-Makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" clean edlis eisl
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe edlis eisl
+
+ # Compilation of ISLisp files on installation fails.
+ # Do not compile them and mimic "make install".
+ insinto "/usr/share/${PN}"
+ doins -r library
+ doins fast.h ffi.h
+
+ einstalldocs
+}