summaryrefslogtreecommitdiff
path: root/dev-lang/dafny-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-28 06:30:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-28 06:30:54 +0000
commit72fd2b48b7154274a1d2009cdaab54e7f49fb3aa (patch)
tree9c6ce981e8f924eb5f24e71e13c91b37aafb8616 /dev-lang/dafny-bin
parent721e451ec418e1712f6962404e111f0ebd487389 (diff)
gentoo auto-resync : 28:12:2024 - 06:30:54
Diffstat (limited to 'dev-lang/dafny-bin')
-rw-r--r--dev-lang/dafny-bin/Manifest2
-rw-r--r--dev-lang/dafny-bin/dafny-bin-4.9.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index b833bdf824e4..c91834ffb765 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1,3 +1,5 @@
DIST dafny-4.9.0-x64-ubuntu-20.04.zip 60772912 BLAKE2B 5904811590362705183e05e38c5f67a98b1601c28b4776faf3f33ac87d527e2c91493a0a693fd635799b8f416344acab2ed8c2897f3d1f07827e34565e8d720e SHA512 f44b94abf4fb9b42ee7b7fab584d1b6d65a90bdc515b2b4fc398762bcc33a759bbe2e22ff0c9fc556ca1794707cd7ca440e414c51be10ecd87a5b470df661bbf
+DIST dafny-4.9.1-x64-ubuntu-20.04.zip 60815385 BLAKE2B 76e4b7cf6bfea6f97bb04b77c034cf62732cc9fcadf1893f4783cf9e44cffc81f4067bbc001474b3b0a92f699b329f87ec77a2e34747a945d7786a33e6fff5b6 SHA512 37fdc7ab2f3feab6cce86103d57248e671daca91aead6588cb9f8de34e4b229178cb2da8bcc5bc26a45b85b76bb445c4c87c440d6e6a84409e2a3fdf7d34765f
EBUILD dafny-bin-4.9.0.ebuild 1276 BLAKE2B f37bffa5af5c63da4b94e5ae203e46673fcc3797b12d60396981ef986d3a1d3b24df58ea5ce9a044613a6d0db4c8bce0282cc3a46f7f0355a4a610876a12de3d SHA512 35d347e45e9fca8bc06868284a48a9d38fb91ff3a8febe57b75c974869c67a6f75a3543ccf6d7a07503a374566b1c9a134abcf794aff783fb85cd24a078cb7d9
+EBUILD dafny-bin-4.9.1.ebuild 1277 BLAKE2B 7b7b9ed62e8030776ffc5d11154069e35653b4809cb9d7463e8081d22ea9170dd8d657fade500796411bb6158c05d73d3d626a71d2dd9c1524df5740a736fb1b SHA512 4dccece78502cd9c3b99e32fe6ff1043fe9f6139bb497fb4872fd0740e950d259ea5aee285941c1b59b9490e789ff3a670c517dea81a48820eac8ebd89e927fd
MISC metadata.xml 1826 BLAKE2B 66f000cee8fbf3bcae05da9249d5bc3388f9c05f32c45e96dd51b035aea220a9d49af25cb89b8b8a64a691408373c1ea02d0f345f9a4a554565f708a894664d5 SHA512 0cc12d9c49360bbc08bb8eccd3f7139ec149a9b731f0283b0f95a8506dd93458eb93f3347a978e55a86279ad85ee3233c1b87bfee36f22c9e40bdd14c0aef6c5
diff --git a/dev-lang/dafny-bin/dafny-bin-4.9.1.ebuild b/dev-lang/dafny-bin/dafny-bin-4.9.1.ebuild
new file mode 100644
index 000000000000..2907f72117f4
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-4.9.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/
+ https://github.com/dafny-lang/dafny/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-20.04.zip"
+S="${WORKDIR}/dafny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="elibc_glibc"
+RESTRICT="strip"
+
+RDEPEND="
+ !dev-lang/dafny
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust:0/2.12
+ sci-mathematics/z3
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used
+ # by, for example, compiling/verifying a simple dafny program.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest="/opt/dafny"
+
+ insinto "${dest}"
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym "../../${dest}/${bin}" "/usr/bin/${bin}"
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym -r "/${dest}/DafnyServer" /usr/bin/dafny-server
+}