summaryrefslogtreecommitdiff
path: root/dev-lang/dafny-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-lang/dafny-bin
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-lang/dafny-bin')
-rw-r--r--dev-lang/dafny-bin/Manifest3
-rw-r--r--dev-lang/dafny-bin/dafny-bin-3.7.1-r2.ebuild50
-rw-r--r--dev-lang/dafny-bin/metadata.xml33
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
new file mode 100644
index 000000000000..c2184c969422
--- /dev/null
+++ b/dev-lang/dafny-bin/Manifest
@@ -0,0 +1,3 @@
+DIST dafny-3.7.1-x64-ubuntu-16.04.zip 76008449 BLAKE2B 5685dcc04e750960fa9bed536d6fae8f70979be899349eaab54bb7045a6e6a9849988be10db3ad33c9096a8d91d17f7b055e50507f736a169aa4fdcb6654b8f6 SHA512 689f3a125e336806c7fe15a8e0cc95e3242f99b719bfae57715313699880c21b13cf2eddfe4163e40da8de20f81c7148dce132dbc511b7a5c2320c1e96d2040a
+EBUILD dafny-bin-3.7.1-r2.ebuild 1166 BLAKE2B 066750b3d98c2d45365ac4fac90d43f823136a5df64fc81c6f035fe8a332ed15c1af46af5b52fd3f711377fb4204879c036fd4e7b3d5dbaca7072e8d1be9cd75 SHA512 17ec7f94bbc31b704fbd8707321e35ef2ae0dbf6f20137fab34f4c6dce5fc7c34bcde0022f4ed053c2257992ff7b6402c10f1954dccbcb1656a9c96b01e5c695
+MISC metadata.xml 1814 BLAKE2B cf1e080cccf3392a44bbf4b94350cf2d83b4704120c193421e5b0952e36bd07d5d2079968c8fc39b4cfc78daf2fb6aa8e58e71b92d4cf1abe3a7cf4297edb750 SHA512 dfd3eb544a7e76ae7d40a993559291348c3ecb58d433f90b44cb67743879e2ca1f7bb249135e39a98b6c41dd32f439c165a4ad0e6a3bd7572f5786b346df70bb
diff --git a/dev-lang/dafny-bin/dafny-bin-3.7.1-r2.ebuild b/dev-lang/dafny-bin/dafny-bin-3.7.1-r2.ebuild
new file mode 100644
index 000000000000..8601d4b64977
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-3.7.1-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-16.04.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64" # Binaries are compiled only for x86_64.
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust
+ sci-mathematics/z3
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/dafny
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym ../../${dest}/DafnyServer /usr/bin/dafny-server
+}
diff --git a/dev-lang/dafny-bin/metadata.xml b/dev-lang/dafny-bin/metadata.xml
new file mode 100644
index 000000000000..f0b8fd07b684
--- /dev/null
+++ b/dev-lang/dafny-bin/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Dafny is a verification-ready programming language. As you type in your
+ program, Dafny's verifier constantly looks over your shoulder, flags any
+ errors, shows you counterexamples, and congratulates you when your code
+ matches your specifications. When you're done, Dafny can compile your code
+ to C#, Java, JavaScript or Go (more to come!), so it can integrate with
+ your existing workflow. Dafny will give you assurance that your code meets
+ the specifications you write, while letting you write both code and
+ specifications in the Dafny programming language itself. Since verification
+ is an integral part of development, it will thus reduce the risk of costly
+ late-stage bugs that are typically missed by testing. Dafny has support for
+ common programming concepts such as classes and trait inheritance,
+ inductive datatypes that can have methods and are suitable for pattern
+ matching, lazily unbounded datatypes, subset types e.g. for bounded
+ integers, lambdas, and immutable and mutable data structures. Dafny also
+ offers an extensive toolbox for mathematical proofs, such as unbounded and
+ bounded quantifiers, calculational proofs, pre- and post-conditions,
+ termination conditions, loop invariants, and read/write specifications.
+ </longdescription>
+ <upstream>
+ <changelog>https://github.com/dafny-lang/dafny/releases/</changelog>
+ <bugs-to>https://github.com/dafny-lang/dafny/issues/</bugs-to>
+ <remote-id type="github">dafny-lang/dafny</remote-id>
+ </upstream>
+</pkgmetadata>