summaryrefslogtreecommitdiff
path: root/dev-lang/dafny-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-13 05:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-13 05:39:05 +0000
commit22b4e2ee9c8011b75d7c030d6129a7487494aeba (patch)
treedac0fe56378ac0d61ca4558245fb3702bbf89821 /dev-lang/dafny-bin
parent05644e4ce4886d97a712fcdca7d4144a7ced4191 (diff)
gentoo auto-resync : 13:12:2023 - 05:39:04
Diffstat (limited to 'dev-lang/dafny-bin')
-rw-r--r--dev-lang/dafny-bin/Manifest2
-rw-r--r--dev-lang/dafny-bin/dafny-bin-4.4.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/Manifest b/dev-lang/dafny-bin/Manifest
index 3da1503c197c..2a3fdcd80bf1 100644
--- a/dev-lang/dafny-bin/Manifest
+++ b/dev-lang/dafny-bin/Manifest
@@ -1,3 +1,5 @@
DIST dafny-4.3.0-x64-ubuntu-20.04.zip 62691627 BLAKE2B edbff278472e5b0494fac38907adefa8fcfb94c3675df828e9ee022429d9595eed398d95333b223a70040ed69f07682e8aeaf90978f7466f4b9a412207d54d58 SHA512 14a861a6b0b55ee71db08f4c73e741fd92e5433d62411a2b17b177470b23148e288d835f80c2bdb388297f37be249b8a47bd3f83c2268082248f27d218b9cb9a
+DIST dafny-4.4.0-x64-ubuntu-20.04.zip 62873378 BLAKE2B ee471dfc0be515949bc3ec18cd46705ce35c7a0b43b8ffc35e7754cef57a3e9351b7e937b6735319d6255407b6cb46b4c0c69eab5a573fdf7671055efe3988b8 SHA512 acfd643bdf3dba7377fde8d36f3c7bfff27b575fbc212d02974958ad38fe433870128525ff22f9a76d4b1602d5253794409ce834b67c52571d395a737fc24471
EBUILD dafny-bin-4.3.0.ebuild 1248 BLAKE2B eeb83043f8a550e1d0ac56a4d2034a39e669178401ef55a5d2b8c87ae45b83ed426cd86d93e96624c5ab5fd2956cb4bac25b13e0a0c3ad2807f2b8e4e361c7f4 SHA512 51220d01035fec12e5ee8ade6e2b788c793c2e3733e71034794663e197a234140faced612d427e6c4125e5de50b4c38cba3460f47db9c2cdc3cd52e6fc084f9e
+EBUILD dafny-bin-4.4.0.ebuild 1249 BLAKE2B e25e6e96b29c5ae6dbe22070f3a7e3245ccc63b066cb877c01f22088c2a0d784e7438efdac5b591bb53c91d7b4f61d934bbe6dad24a4526d58bd6afbed2e6e6e SHA512 11faa5f2152608d35ad6576fdfb972b91bda58677679697a349e237e73e1dac768c8b1224811561d51fa75c5db4fbae366d2018a3eddd2657c2add46431f6040
MISC metadata.xml 1826 BLAKE2B 66f000cee8fbf3bcae05da9249d5bc3388f9c05f32c45e96dd51b035aea220a9d49af25cb89b8b8a64a691408373c1ea02d0f345f9a4a554565f708a894664d5 SHA512 0cc12d9c49360bbc08bb8eccd3f7139ec149a9b731f0283b0f95a8506dd93458eb93f3347a978e55a86279ad85ee3233c1b87bfee36f22c9e40bdd14c0aef6c5
diff --git a/dev-lang/dafny-bin/dafny-bin-4.4.0.ebuild b/dev-lang/dafny-bin/dafny-bin-4.4.0.ebuild
new file mode 100644
index 000000000000..0f5cd85b46af
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-4.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/
+ https://github.com/dafny-lang/dafny/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-20.04.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ !dev-lang/dafny
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust:0/2.12
+ sci-mathematics/z3
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/dafny"
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used
+ # by, for example, compiling/verifying a simple dafny program.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym ../../${dest}/DafnyServer /usr/bin/dafny-server
+}