summaryrefslogtreecommitdiff
path: root/dev-lang/dafny-bin/dafny-bin-3.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-22 08:46:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-22 08:46:22 +0100
commit593b66fb6ac6aa53bd2016d7409fc12a22a10214 (patch)
treef1893f7d402a12427b5b177f2d58e95607e175a8 /dev-lang/dafny-bin/dafny-bin-3.7.3.ebuild
parent52fc263f2dd029a99ad4f0e5e1c3dbfd490d6b63 (diff)
gentoo auto-resync : 22:07:2022 - 08:46:22
Diffstat (limited to 'dev-lang/dafny-bin/dafny-bin-3.7.3.ebuild')
-rw-r--r--dev-lang/dafny-bin/dafny-bin-3.7.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-lang/dafny-bin/dafny-bin-3.7.3.ebuild b/dev-lang/dafny-bin/dafny-bin-3.7.3.ebuild
new file mode 100644
index 000000000000..8601d4b64977
--- /dev/null
+++ b/dev-lang/dafny-bin/dafny-bin-3.7.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Verification-aware programming language"
+HOMEPAGE="https://dafny.org/"
+SRC_URI="https://github.com/dafny-lang/dafny/releases/download/v${PV}/dafny-${PV}-x64-ubuntu-16.04.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64" # Binaries are compiled only for x86_64.
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ dev-libs/userspace-rcu
+ dev-util/lttng-ust
+ sci-mathematics/z3
+"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/dafny
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # Remove bundled z3.
+ # NOTICE: New versions do not need the bundled one but older versions
+ # hardcoded the path relative to "dafny" binary.
+ # While bumping make sure to verify that system's "z3" is used.
+ rm -r z3 || die
+}
+
+src_install() {
+ local dest=/opt/dafny
+
+ insinto ${dest}
+ # Maybe too general, but this installation mode matched how it arrives.
+ insopts -m0755
+ doins "${S}"/*
+
+ local bin
+ for bin in DafnyServer dafny ; do
+ dosym ../../${dest}/${bin} /usr/bin/${bin}
+ done
+
+ # Make "dafny-server" clients happy.
+ dosym ../../${dest}/DafnyServer /usr/bin/dafny-server
+}