summaryrefslogtreecommitdiff
path: root/dev-lang/crystal/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-lang/crystal/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-lang/crystal/files')
-rw-r--r--dev-lang/crystal/files/crystal-0.22.0-blocking-stdio-hack.patch20
-rw-r--r--dev-lang/crystal/files/crystal-0.23.0-verbose-LDFLAGS.patch9
-rw-r--r--dev-lang/crystal/files/crystal-0.24.0-verbose-LDFLAGS.patch9
-rw-r--r--dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-network-sandbox.patch33
-rw-r--r--dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-sandbox.patch37
-rw-r--r--dev-lang/crystal/files/crystal-0.25.0-verbose.patch9
6 files changed, 0 insertions, 117 deletions
diff --git a/dev-lang/crystal/files/crystal-0.22.0-blocking-stdio-hack.patch b/dev-lang/crystal/files/crystal-0.22.0-blocking-stdio-hack.patch
deleted file mode 100644
index 07b7dba7be65..000000000000
--- a/dev-lang/crystal/files/crystal-0.22.0-blocking-stdio-hack.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Workaround tty corruption in crystal.
-
-Patch restores blocking mode of file desriptors
-in exchange of potential runtime deadlocks
-when dealing with stdio.
-
-Reported-by: Renich Bon Ciric
-Bug: https://github.com/crystal-lang/crystal/issues/2065
-Bug: https://bugs.gentoo.org/616256
-diff --git a/src/compiler/crystal/stdio.cr b/src/compiler/crystal/stdio.cr
-new file mode 100644
-index 000000000..e65f65089
---- /dev/null
-+++ b/src/compiler/crystal/stdio.cr
-@@ -0,0 +1,5 @@
-+module Crystal
-+ STDIN.blocking = true
-+ STDOUT.blocking=true
-+ STDERR.blocking = true
-+end
diff --git a/dev-lang/crystal/files/crystal-0.23.0-verbose-LDFLAGS.patch b/dev-lang/crystal/files/crystal-0.23.0-verbose-LDFLAGS.patch
deleted file mode 100644
index 35eace15dae0..000000000000
--- a/dev-lang/crystal/files/crystal-0.23.0-verbose-LDFLAGS.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/Makefile b/Makefile
-index eff69e5..5c0c024 100644
---- a/Makefile
-+++ b/Makefile
-@@ -28,3 +28,3 @@ SOURCES := $(shell find src -name '*.cr')
- SPEC_SOURCES := $(shell find spec -name '*.cr')
--FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )
-+FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(verbose),--verbose )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )
- SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )
diff --git a/dev-lang/crystal/files/crystal-0.24.0-verbose-LDFLAGS.patch b/dev-lang/crystal/files/crystal-0.24.0-verbose-LDFLAGS.patch
deleted file mode 100644
index 3d02a119f858..000000000000
--- a/dev-lang/crystal/files/crystal-0.24.0-verbose-LDFLAGS.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/Makefile b/Makefile
-index eff69e5..5c0c024 100644
---- a/Makefile
-+++ b/Makefile
-@@ -28,3 +28,3 @@ SOURCES := $(shell find src -name '*.cr')
- SPEC_SOURCES := $(shell find spec -name '*.cr')
--FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )
-+FLAGS := $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(verbose),--verbose )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )
- SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )
diff --git a/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-network-sandbox.patch b/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-network-sandbox.patch
deleted file mode 100644
index 12565c1d8390..000000000000
--- a/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-network-sandbox.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/spec/std/socket_spec.cr b/spec/std/socket_spec.cr
-index 0caa51a..f21b3b3 100644
---- a/spec/std/socket_spec.cr
-+++ b/spec/std/socket_spec.cr
-@@ -537,13 +537,15 @@ describe TCPSocket do
- end
- end
-
-- it "fails when host doesn't exist" do
-+ # gentoo's FEATURES=network-sandbox blocks DNS
-+ pending "fails when host doesn't exist" do
- expect_raises(Socket::Error, /No address/i) do
- TCPSocket.new("doesnotexist.example.org.", 12345)
- end
- end
-
-- it "fails (rather than segfault on darwin) when host doesn't exist and port is 0" do
-+ # gentoo's FEATURES=network-sandbox blocks DNS
-+ pending "fails (rather than segfault on darwin) when host doesn't exist and port is 0" do
- expect_raises(Socket::Error, /No address/i) do
- TCPSocket.new("doesnotexist.example.org.", 0)
- end
-@@ -634,7 +636,9 @@ describe UDPSocket do
- client.close
- end
-
-- it "broadcasts messages" do
-+ # gentoo's FEATURES=network-sandbox blocks external network:
-+ # connect: Network is unreachable
-+ pending "broadcasts messages" do
- port = free_udp_socket_port
-
- client = UDPSocket.new(Socket::Family::INET)
diff --git a/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-sandbox.patch b/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-sandbox.patch
deleted file mode 100644
index 4bd779a834c8..000000000000
--- a/dev-lang/crystal/files/crystal-0.24.2-gentoo-tests-sandbox.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/spec/std/file_spec.cr b/spec/std/file_spec.cr
-index 4a08b7d..cb1b28c 100644
---- a/spec/std/file_spec.cr
-+++ b/spec/std/file_spec.cr
-@@ -1026,7 +1026,8 @@ describe "File" do
- end
- end
-
-- it "raises if file cannot be accessed" do
-+ # On linux it's "Permission denied", not "Operation not permitted"
-+ pending "raises if file cannot be accessed" do
- expect_raises Errno, "Operation not permitted" do
- File.touch("/bin/ls")
- end
-diff --git a/spec/std/process_spec.cr b/spec/std/process_spec.cr
-index 4a36f18..0cd63a8 100644
---- a/spec/std/process_spec.cr
-+++ b/spec/std/process_spec.cr
-@@ -115,14 +115,16 @@ describe Process do
- end
-
- describe "environ" do
-- it "clears the environment" do
-+ #gentoo's sandbox keeps sandbox environment
-+ pending "clears the environment" do
- value = Process.run("env", clear_env: true) do |proc|
- proc.output.gets_to_end
- end
- value.should eq("")
- end
-
-- it "sets an environment variable" do
-+ #gentoo's sandbox keeps sandbox environment
-+ pending "sets an environment variable" do
- env = {"FOO" => "bar"}
- value = Process.run("env", clear_env: true, env: env) do |proc|
- proc.output.gets_to_end
diff --git a/dev-lang/crystal/files/crystal-0.25.0-verbose.patch b/dev-lang/crystal/files/crystal-0.25.0-verbose.patch
deleted file mode 100644
index c26e12335e67..000000000000
--- a/dev-lang/crystal/files/crystal-0.25.0-verbose.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 63a9687..995299f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -29,3 +29,3 @@ SOURCES := $(shell find src -name '*.cr')
- SPEC_SOURCES := $(shell find spec -name '*.cr')
--override FLAGS += $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )
-+override FLAGS += $(if $(release),--release )$(if $(stats),--stats )$(if $(progress),--progress )$(if $(threads),--threads $(threads) )$(if $(debug),-d )$(if $(static),--static )$(if $(LDFLAGS),--link-flags="$(LDFLAGS)" )$(if $(verbose),--verbose )
- SPEC_FLAGS := $(if $(verbose),-v )$(if $(junit_output),--junit_output $(junit_output) )