summaryrefslogtreecommitdiff
path: root/dev-lang/cfortran/cfortran-20110621.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-lang/cfortran/cfortran-20110621.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-lang/cfortran/cfortran-20110621.ebuild')
-rw-r--r--dev-lang/cfortran/cfortran-20110621.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-lang/cfortran/cfortran-20110621.ebuild b/dev-lang/cfortran/cfortran-20110621.ebuild
index e61e831fc6a1..9a624c62ccf7 100644
--- a/dev-lang/cfortran/cfortran-20110621.ebuild
+++ b/dev-lang/cfortran/cfortran-20110621.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
FORTRAN_NEEDED=test
-inherit autotools fortran-2
+inherit autotools fortran-2 flag-o-matic
DEB_PR="1"
@@ -17,7 +17,7 @@ SRC_URI="
SLOT="0"
LICENSE="LGPL-2"
-KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
IUSE="examples test"
RESTRICT="!test? ( test )"
@@ -38,6 +38,11 @@ src_prepare() {
fi
}
+src_configure() {
+ use sparc && append-fflags $(test-flags-FC -fno-store-merging -fno-tree-slp-vectorize) # bug 818400
+ default
+}
+
src_install() {
default