summaryrefslogtreecommitdiff
path: root/dev-lang/algol68g/algol68g-3.4.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-15 23:10:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-15 23:10:09 +0000
commit02f2811de683662c5c6f5f120de6b59898ed6b98 (patch)
tree3f181b9668c22e5f983e5215c49ebca4f93d8154 /dev-lang/algol68g/algol68g-3.4.6.ebuild
parent4c588f061163483deaeecd52e6a5743762d2603e (diff)
gentoo auto-resync : 15:01:2024 - 23:10:08
Diffstat (limited to 'dev-lang/algol68g/algol68g-3.4.6.ebuild')
-rw-r--r--dev-lang/algol68g/algol68g-3.4.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-lang/algol68g/algol68g-3.4.6.ebuild b/dev-lang/algol68g/algol68g-3.4.6.ebuild
new file mode 100644
index 000000000000..6689c5616025
--- /dev/null
+++ b/dev-lang/algol68g/algol68g-3.4.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Algol 68 Genie compiler-interpreter"
+HOMEPAGE="https://jmvdveer.home.xs4all.nl/en.algol-68-genie.html"
+SRC_URI="https://jmvdveer.home.xs4all.nl/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl +gsl +mpfr +ncurses plotutils postgres +readline"
+
+RDEPEND="
+ curl? ( net-misc/curl )
+ gsl? ( sci-libs/gsl:= )
+ mpfr? ( dev-libs/mpfr:= )
+ plotutils? ( media-libs/plotutils )
+ postgres? ( dev-db/postgresql:* )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.21-configure-implicit.patch" )
+
+src_configure() {
+ local -a myconf=(
+ $(use_enable curl)
+ $(use_enable gsl)
+ $(use_enable mpfr)
+ $(use_enable ncurses curses)
+ $(use_enable plotutils)
+ $(use_enable postgres postgresql)
+ $(use_enable readline)
+ $(use_with ncurses)
+ )
+ econf "${myconf[@]}"
+}