summaryrefslogtreecommitdiff
path: root/dev-java
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-29 15:22:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-29 15:22:55 +0100
commit3a2444aaf0bafd5c58c0dc8dda102352f20c76d8 (patch)
tree055720c0e02ac3f8bc4255b6740f18ba32db1c54 /dev-java
parentb94ab464dd0d948b7e7eac833b9bb51c03515918 (diff)
gentoo auto-resync : 29:09:2022 - 15:22:54
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/Manifest.gzbin54041 -> 53880 bytes
-rw-r--r--dev-java/byte-buddy-agent/Manifest4
-rw-r--r--dev-java/byte-buddy-agent/byte-buddy-agent-1.12.10.ebuild87
-rw-r--r--dev-java/byte-buddy-agent/metadata.xml10
4 files changed, 0 insertions, 101 deletions
diff --git a/dev-java/Manifest.gz b/dev-java/Manifest.gz
index 00a20e9e264d..5ef1f2b664a6 100644
--- a/dev-java/Manifest.gz
+++ b/dev-java/Manifest.gz
Binary files differ
diff --git a/dev-java/byte-buddy-agent/Manifest b/dev-java/byte-buddy-agent/Manifest
deleted file mode 100644
index 1557ff735486..000000000000
--- a/dev-java/byte-buddy-agent/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST byte-buddy-1.12.10.tar.gz 149932619 BLAKE2B dce562c72fce2b4c6f7d7b49192297929c6828b5157db81825199eb6636a6aadfa27240cf69e6ebfef7e809b35aec0037461ec4b30c7633cb700f55458238058 SHA512 5f8c9e94e3661978e51134a65842e376b96acfe25e940c565a2647bec54bb7c40b12501b590019270ce470efc4ca8f4dd0a7ffe7c6d5d2854b768c28c84920a6
-DIST byte-buddy-agent-1.12.10-sources.jar 204651 BLAKE2B f3e0db8e6c8f3380ee3bfd8969555c331689990b97e91206567c01ffbaabc58eeb25b0879e792ebce1044afa8d3b5596830349d9c233ab1af84d13213e046f4d SHA512 8569531e5f5343378037cd9740bdc42b91becb9adaf0f2cacbdcb0e5ccafb3e47fce9c7b71d8d8d8df1c7373ffd44d798b8b164136d87913faed1e19474f803d
-EBUILD byte-buddy-agent-1.12.10.ebuild 3896 BLAKE2B 026356551487c0b98673d48fcc48f98ff5407d8934e3be3b212b5e71e908baa4e08e5d7dffd3ff785b551fa0edc587a036db5d549cd1abffeeadd68d66c29389 SHA512 53a612eb49dc6ddc972e784b9e339866bd07cfe514691741dc904d4a51b8e34a5da7ddfbcc7a67d14a4cc6575ecd50a3669c3ca25e0832e5e3aea84508ceec70
-MISC metadata.xml 298 BLAKE2B 914c744490ae973853ca6466984c1037b03e9fca047e413a4c6981122c796312f56510069c6ac3c7cbc4ade7f45d480b4aa6ad0dbeb5e9c19e552aa136308626 SHA512 6483fd3b6cf22d595b2d925d81b5450f1bbe5b0b371bf4bd221a7433d9eeec5824c2dc644a77cb4206a6bcc017172f764f050eda9dd6f479fe408d491b325f5a
diff --git a/dev-java/byte-buddy-agent/byte-buddy-agent-1.12.10.ebuild b/dev-java/byte-buddy-agent/byte-buddy-agent-1.12.10.ebuild
deleted file mode 100644
index dd14f79475bf..000000000000
--- a/dev-java/byte-buddy-agent/byte-buddy-agent-1.12.10.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom byte-buddy-agent-1.12.10.pom --download-uri https://repo1.maven.org/maven2/net/bytebuddy/byte-buddy-agent/1.12.10/byte-buddy-agent-1.12.10.jar --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild byte-buddy-agent-1.12.10.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="net.bytebuddy:byte-buddy-agent:1.12.10"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Offers convenience for attaching an agent to the local or a remote VM"
-HOMEPAGE="https://bytebuddy.net/"
-SRC_URI="https://repo1.maven.org/maven2/net/bytebuddy/${PN}/${PV}/${P}-sources.jar
- test? ( https://github.com/raphw/byte-buddy/archive/byte-buddy-${PV}.tar.gz )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-# Compile dependencies
-# POM: ${P}.pom
-# com.google.code.findbugs:findbugs-annotations:3.0.1 -> >=dev-java/findbugs-annotations-3.0.1:0
-# com.google.code.findbugs:jsr305:3.0.2 -> >=dev-java/jsr305-3.0.2:0
-# net.java.dev.jna:jna:5.8.0 -> >=dev-java/jna-5.10.0:4
-# net.java.dev.jna:jna-platform:5.8.0 -> !!!artifactId-not-found!!!
-
-DEPEND="
- >=virtual/jdk-1.8:*
- dev-java/findbugs-annotations:0
- dev-java/jna:4
- test? ( dev-java/mockito:4 )
-"
-
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-BDEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
-
-JAVA_CLASSPATH_EXTRA="findbugs-annotations,jna-4"
-JAVA_SRC_DIR="src/main/java"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit-4,mockito-4"
-JAVA_TEST_SRC_DIR="src/test/java"
-
-# 1) testSystemProperties(net.bytebuddy.agent.VirtualMachineAttachmentTest)
-# java.lang.reflect.InvocationTargetException
-# --
-# Caused by: java.lang.UnsatisfiedLinkError: Native library (com/sun/jna/linux-x86-64/libjnidispatch.so) not found in resource path (target/test-classes:byte-buddy-agent.jar:/usr/share/findbugs-annotations/lib/findbugs-annotations.jar:/usr/share/jna-4/lib/jna.jar:/usr/share/jna-4/lib/jna-platform.jar:/usr/share/jsr305/lib/jsr305.jar:/usr/share/junit-4/lib/junit.jar:/usr/share/mockito-4/lib/mockito.jar:/usr/share/hamcrest-core-1.3/lib/hamcrest-core.jar:/usr/share/byte-buddy/lib/byte-buddy.jar:/usr/share/byte-buddy-agent/lib/byte-buddy-agent.jar:/usr/share/objenesis/lib/objenesis.jar:/usr/share/opentest4j/lib/opentest4j.jar:/usr/share/junit-4/lib/junit.jar:/usr/share/hamcrest-core-1.3/lib/hamcrest-core.jar)
-# at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:1059)
-# --
-# 2) testAgentProperties(net.bytebuddy.agent.VirtualMachineAttachmentTest)
-# java.lang.reflect.InvocationTargetException
-# --
-# Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
-# at net.bytebuddy.agent.VirtualMachine$ForHotSpot$Connection$ForJnaPosixSocket$Factory.<init>(VirtualMachine.java:879)
-# --
-# 3) testMultipleProperties(net.bytebuddy.agent.VirtualMachineAttachmentTest)
-# java.lang.reflect.InvocationTargetException
-# --
-# Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
-# at net.bytebuddy.agent.VirtualMachine$ForHotSpot$Connection$ForJnaPosixSocket$Factory.<init>(VirtualMachine.java:879)
-# --
-# 4) testAttachment(net.bytebuddy.agent.VirtualMachineAttachmentTest)
-# java.lang.reflect.InvocationTargetException
-# --
-# Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
-# at net.bytebuddy.agent.VirtualMachine$ForHotSpot$Connection$ForJnaPosixSocket$Factory.<init>(VirtualMachine.java:879)
-# --
-# FAILURES!!!
-# Tests run: 51, Failures: 4
-JAVA_TEST_EXCLUDES="net.bytebuddy.agent.VirtualMachineAttachmentTest"
-
-src_prepare() {
- default
- mkdir -p "src/main/java" || die
- mv "net" "src/main/java" || die
- if use test; then
- mv "byte-buddy-byte-buddy-${PV}/byte-buddy-agent/src/test" "src" || die
- fi
-}
diff --git a/dev-java/byte-buddy-agent/metadata.xml b/dev-java/byte-buddy-agent/metadata.xml
deleted file mode 100644
index 02d6cbf56ced..000000000000
--- a/dev-java/byte-buddy-agent/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">raphw/byte-buddy</remote-id>
- </upstream>
-</pkgmetadata>