summaryrefslogtreecommitdiff
path: root/dev-java/xml-commons/xml-commons-1.4.01.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/xml-commons/xml-commons-1.4.01.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/xml-commons/xml-commons-1.4.01.ebuild')
-rw-r--r--dev-java/xml-commons/xml-commons-1.4.01.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/xml-commons/xml-commons-1.4.01.ebuild b/dev-java/xml-commons/xml-commons-1.4.01.ebuild
new file mode 100644
index 000000000000..25d9caa3b6a6
--- /dev/null
+++ b/dev-java/xml-commons/xml-commons-1.4.01.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+MY_PN="${PN}-external"
+MY_P="${MY_PN}-${PV}"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache XML Commons"
+HOMEPAGE="http://xml.apache.org/commons/"
+SRC_URI="mirror://apache/xerces/${PN}/source/${MY_P}-src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-1.1 public-domain W3C-document W3C"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+JAVA_SRC_DIR="org javax"