summaryrefslogtreecommitdiff
path: root/dev-java/xjavac/xjavac-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/xjavac/xjavac-2.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/xjavac/xjavac-2.4.0.ebuild')
-rw-r--r--dev-java/xjavac/xjavac-2.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/xjavac/xjavac-2.4.0.ebuild b/dev-java/xjavac/xjavac-2.4.0.ebuild
new file mode 100644
index 000000000000..a2928dde6b81
--- /dev/null
+++ b/dev-java/xjavac/xjavac-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Xerses Java Parser"
+HOMEPAGE="https://xerces.apache.org/xerces-j"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+CDEPEND="dev-java/ant-core:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.7"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.7"
+
+JAVA_GENTOO_CLASSPATH="ant-core"