summaryrefslogtreecommitdiff
path: root/dev-java/xerces
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
commit7b830374520118e805fdd214530a389653750f51 (patch)
tree1f6ef2872a3f89b278b2d5c7f82f36df335dce30 /dev-java/xerces
parent3c490942d0d98701d1c0971e60911fa6bd3ecb76 (diff)
gentoo auto-resync : 16:09:2023 - 17:00:58
Diffstat (limited to 'dev-java/xerces')
-rw-r--r--dev-java/xerces/Manifest2
-rw-r--r--dev-java/xerces/xerces-2.12.2-r1.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-java/xerces/Manifest b/dev-java/xerces/Manifest
index 04e9c739b8c7..26f463f0e743 100644
--- a/dev-java/xerces/Manifest
+++ b/dev-java/xerces/Manifest
@@ -1,3 +1,5 @@
DIST Xerces-J-src.2.12.2.tar.gz 1812583 BLAKE2B f1b5928abe2852acc4d554c47aa7cbd81a568e15c8a1fd5ea98dc526c52838b0a50920d2ed807e607b01c875676e54578f1493856b06de5a7ba8784591f7f06f SHA512 e71a692212a974ebfa39af5ffd023b433ece34425b12aceeffe89cebe04f28dd8fa46a131a56f30295dca36de115128a6d7e05172c82f5b85d914cd991f34056
+DIST Xerces-J-src.2.12.2.tar.gz.asc 849 BLAKE2B 58faca219413b5b13ded6bedb16acca5ffe53a6890c2ea6ec6f5b2b19b46b179bd74b225e608b936b0d6abad24b947930da24339256137a291e5bc863a11c416 SHA512 77cc480b9eff693ab7b5fe4c8a8963cbd53e895dd130bc0ef3fbaebce6d64e59c068806f10bbf650f51a4fb132a49d24c869c8a01e9922bf792bb479602b9846
+EBUILD xerces-2.12.2-r1.ebuild 2171 BLAKE2B 6a3077886897bbbf7e5213f90ebe6deffc9d6894a3764331bbcf2f6ce93fb3676cebc93f449dedb7991e90143475fdeb0acc851d4b05a8dc9691a603cae08b95 SHA512 b2197bafeca6ff6279856d5a2f48eb1b5b218b8573427bbccc4ddd752b2bc0090bbec3cf97ea26df408bf5e68dfbe13cd7fe93a78d8c5ee190da2d7d65e24c07
EBUILD xerces-2.12.2.ebuild 1735 BLAKE2B 71ce08db857c0a816a40a10f11829c52964ff186db96783f05972997237e7b6a45cacf1aef0cb4ffe75ca4c8605f0a3ae26ee425fbd4e464acce08fc131fb866 SHA512 b889a86e6f5016aa2a27e57d964bccb2fd2cbd709806812484205387b68a636731200cf6ab876969bda340a132b5b3c5f7d0e87e697d13b26e649e9057e093d6
MISC metadata.xml 1778 BLAKE2B 458bcbd9e8adfab1d2bd25a5fe9de0bee48292cb57e3591821fade58a987e59cb9811800273ac62b525738e7e955514b8b77c27fe97d9040bad0db203e6171a4 SHA512 ccbd7007ce2efe5b19d300ba939abe4e756d65eb1c910c74c5f3f13410de0d75e83bfd82d1e226e5dc1180982a1bfe231d30cb849f60142a177cc9aeb087c91f
diff --git a/dev-java/xerces/xerces-2.12.2-r1.ebuild b/dev-java/xerces/xerces-2.12.2-r1.ebuild
new file mode 100644
index 000000000000..d21f43579ee1
--- /dev/null
+++ b/dev-java/xerces/xerces-2.12.2-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="xerces:xercesImpl:2.12.2"
+
+inherit java-pkg-2 java-pkg-simple verify-sig
+
+DESCRIPTION="Xerces Java XML parser"
+HOMEPAGE="https://xerces.apache.org/xerces2-j/index.html"
+SRC_URI="mirror://apache/xerces/j/source/Xerces-J-src.${PV}.tar.gz
+ verify-sig? ( https://downloads.apache.org/xerces/j/source/Xerces-J-src.${PV}.tar.gz.asc )"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+CP_DEPEND="
+ dev-java/xml-commons-external:1.4
+ dev-java/xml-commons-resolver:0"
+
+# JDK 11+ already privides the following file and the compilation
+# fails if xerces provides it too. On contrary, compilation on 1.8
+# fails if we don't provide the file because it's not part of 1.8.
+# By restricting compilation to 1.8 and providing the file we build
+# a jar that should work both on 1.8 and also on the newer versions
+# of JDK.
+# the file: "org/w3c/dom/html/HTMLDOMImplementation.class"
+DEPEND="
+ ${CP_DEPEND}
+ virtual/jdk:1.8"
+
+RDEPEND="
+ ${CP_DEPEND}
+ >=virtual/jre-1.8:*"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-apache-xerces-j )"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/xerces-j.apache.org.asc"
+
+DOCS=( LICENSE NOTICE README {LICENSE.resolver,LICENSE.serializer,NOTICE.resolver,NOTICE.serializer}.txt )
+HTML_DOCS=( {LICENSE.DOM-documentation,LICENSE.DOM-software,LICENSE-SAX,Readme}.html )
+
+S="${WORKDIR}/${P//./_}"
+
+JAVA_SRC_DIR="src"
+JAVA_RESOURCE_DIRS="resources"
+
+src_prepare() {
+ java-pkg-2_src_prepare
+ # java-pkg-simple.eclass wants resources in JAVA_RESOURCE_DIRS
+ mkdir -p "resources/META-INF/services"|| die
+ pushd "src" > /dev/null || die
+ find -type f \
+ \( -name 'javax.xml.*Factory' \
+ -or -name '*DOMImplementationSourceList' \
+ -or -name 'org.xml.sax.driver' \) \
+ | xargs mv -t ../resources/META-INF/services || die
+ find -type f \
+ ! -name '*.java' \
+ ! -name 'manifest.xerces' \
+ ! -name 'package.html' \
+ ! -name '*Configuration' \
+ ! -name '*DOMImplementationSourceImpl' \
+ | xargs cp --parent -t ../resources || die
+ popd > /dev/null || die
+}