summaryrefslogtreecommitdiff
path: root/dev-java/stax2-api
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-java/stax2-api
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-java/stax2-api')
-rw-r--r--dev-java/stax2-api/Manifest1
-rw-r--r--dev-java/stax2-api/stax2-api-4.2.1-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/stax2-api/Manifest b/dev-java/stax2-api/Manifest
index b266cce2a596..b0c37b30550f 100644
--- a/dev-java/stax2-api/Manifest
+++ b/dev-java/stax2-api/Manifest
@@ -1,3 +1,4 @@
DIST stax2-api-4.2.1.tar.gz 128806 BLAKE2B 64254b0bbd269e5d62931280773e0e7e7915204ce41a86eb10a08e3d8d27691d48094e17a8deb0ca3fa916b413800d75969af05db1ba897277c0dae13771e3b4 SHA512 f6fada289e75db0c4c911d3f70e8b8167c96342390168c87563ab4e3e1498360d47c393407cd8ae670716fcb7e1c83d6a8d38364d00648ed380844cf08bdc063
+EBUILD stax2-api-4.2.1-r1.ebuild 1045 BLAKE2B bd6faef438c8c68879f579f459c926629d7d94912880d2d62a3287a54987743ce32774ed7891eff643ca7458953175a30743fccb61a42b7d17cd507037d42ba5 SHA512 6219dd8c9acedcd1b675197cc593dd21fffca45b83e9c344a3c7df702e2cb0aa5cb96ad3509d9153cb7895650a728e911688460b13e1cf7174084ca2f9e35be9
EBUILD stax2-api-4.2.1.ebuild 1044 BLAKE2B bcd69c387fc42a8b474b408fec694d46def41c97b06d689d0748c9f399325d31c808301247b8fd0b4d4f596c3bb35e3d9a44ed1b90c5bbd0a3cdc836b851fb75 SHA512 9655f78987b664063072b6ad8f080555328192ffc401dc85a9d4e4d8265c940d7232f1ed76f3cab35cdfcb3369484c687504138eac6db0c95fc06b18d219ddcb
MISC metadata.xml 534 BLAKE2B 53aec30f2ec738fa257cf67be461177475f4706f625a41ec72a51bcc97e16e8fe2ddad45f74e749230e7f668dbb6857d66409413ce462eb13cef793a955e94b2 SHA512 ed2bb40dbbe18087f3b1647878f072be88c57034c9af03cafb4ceebb9f11e84e9309c2a316299938ebbf2e872eed75de19ceb31efc88849b73b527918d540ba9
diff --git a/dev-java/stax2-api/stax2-api-4.2.1-r1.ebuild b/dev-java/stax2-api/stax2-api-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..9e3c9d842122
--- /dev/null
+++ b/dev-java/stax2-api/stax2-api-4.2.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/FasterXML/stax2-api/archive/refs/tags/stax2-api-4.2.1.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild stax2-api-4.2.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.codehaus.woodstox:stax2-api:4.2.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="stax2 API is an extension to basic Stax 1.0 API"
+HOMEPAGE="https://github.com/FasterXML/stax2-api"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm arm64 ppc64 x86"
+
+DEPEND=">=virtual/jdk-1.9:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( README.md release-notes/VERSION )
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR=( "src/main/java" "src/moditect" )
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}